summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 12:30:05 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:27:37 +0200
commit2ee7d72d539753a7e9f9e9752d888f0d9f121f80 (patch)
tree328722b3cf7dfdf7f80fd1403803418b67834cf5 /media-sound/csound/csound-9999.ebuild
parentmedia-sound/ario: [QA] Add missing python metadata variables (diff)
downloadgentoo-2ee7d72d539753a7e9f9e9752d888f0d9f121f80.tar.gz
gentoo-2ee7d72d539753a7e9f9e9752d888f0d9f121f80.tar.bz2
gentoo-2ee7d72d539753a7e9f9e9752d888f0d9f121f80.zip
media-sound/csound: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/csound/csound-9999.ebuild')
-rw-r--r--media-sound/csound/csound-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 06c09139e74e..b67f5ec5779f 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,7 +31,7 @@ REQUIRED_USE="
java? ( cxx )
linear? ( double-precision )
lua? ( cxx )
- python? ( cxx )
+ python? ( ${PYTHON_REQUIRED_USE} cxx )
"
RDEPEND="
@@ -88,12 +88,12 @@ DEPEND="${RDEPEND}
RESTRICT="test"
pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
if use python || use test ; then
python-single-r1_pkg_setup
fi