summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-11-27 16:09:51 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-11-27 16:09:51 +0300
commit622a0356f4db8176c851e608306b95298dbdc0be (patch)
tree6454bd3992923f31a4d750ca6d8f2a15cc2cedad /media-sound/csound/files
parentmedia-sound/csound: fix virtual/jdk dependency warning (diff)
downloadgentoo-622a0356f4db8176c851e608306b95298dbdc0be.tar.gz
gentoo-622a0356f4db8176c851e608306b95298dbdc0be.tar.bz2
gentoo-622a0356f4db8176c851e608306b95298dbdc0be.zip
media-sound/csound: drop old
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound/csound/files')
-rw-r--r--media-sound/csound/files/csound-5.16.6-tests.patch90
-rw-r--r--media-sound/csound/files/csound-5.17.11-cmake.patch10
-rw-r--r--media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch20
-rw-r--r--media-sound/csound/files/csound-5.17.6-fltk.patch10
-rw-r--r--media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch20
-rw-r--r--media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch30
6 files changed, 0 insertions, 180 deletions
diff --git a/media-sound/csound/files/csound-5.16.6-tests.patch b/media-sound/csound/files/csound-5.16.6-tests.patch
deleted file mode 100644
index dd8b8ed289bc..000000000000
--- a/media-sound/csound/files/csound-5.16.6-tests.patch
+++ /dev/null
@@ -1,90 +0,0 @@
---- Csound5.16.6/tests/test.py.orig
-+++ Csound5.16.6/tests/test.py
-@@ -6,9 +6,6 @@
- import os
- import sys
-
--from testUI import TestApplication
--from Tkinter import *
--
- parserType = "--new-parser"
- showUIatClose = False
- csoundExecutable = ""
-@@ -104,8 +101,6 @@
- ]
-
-
-- output = ""
-- tempfile = "/tmp/csound_test_output.txt"
- counter = 1
-
- retVals = []
-@@ -124,7 +119,7 @@
- retVal = os.system(command)
- else:
- executable = (csoundExecutable == "") and "../csound" or csoundExecutable
-- command = "%s %s %s %s &> %s"%(executable, parserType, runArgs, filename, tempfile)
-+ command = "%s %s %s %s"%(executable, parserType, runArgs, filename)
- retVal = os.system(command)
-
- print "Test %i: %s (%s)\nReturn Code: %i"%(counter, desc, filename, retVal)
-@@ -136,24 +131,6 @@
- testFail += 1
- print "Result: FAIL\n"
-
-- output += "%s\n"%("=" * 80)
-- output += "Test %i: %s (%s)\nReturn Code: %i\n"%(counter, desc, filename, retVal)
-- output += "%s\n\n"%("=" * 80)
--
-- f = open(tempfile, "r")
--
-- csOutput = ""
--
-- for line in f:
-- csOutput += line
--
-- output += csOutput
--
-- f.close()
--
-- retVals.append(t + [retVal, csOutput])
--
-- output += "\n\n"
- counter += 1
-
- # print output
-@@ -162,12 +139,7 @@
- print "Tests Passed: %i\nTests Failed: %i\n"%(testPass, testFail)
-
-
-- f = open("results.txt", "w")
-- f.write(output)
-- f.flush()
-- f.close()
--
-- return retVals
-+ return testFail
-
- if __name__ == "__main__":
- if(len(sys.argv) > 1):
-@@ -176,6 +148,8 @@
- showHelp()
- sys.exit(0)
- elif arg == "--show-ui":
-+ from testUI import TestApplication
-+ from Tkinter import *
- showUIatClose = True
- elif arg == "--old-parser":
- parserType = "--old-parser"
-@@ -185,6 +159,8 @@
- elif arg.startswith("--opcodedir64="):
- os.environ['OPCODEDIR64'] = arg[14:]
- print os.environ['OPCODEDIR64']
-- results = runTest()
-- if (showUIatClose):
-- showUI(results)
-+ failures = runTest()
-+ if failures > 0:
-+ sys.exit(1)
-+ else:
-+ sys.exit(0)
diff --git a/media-sound/csound/files/csound-5.17.11-cmake.patch b/media-sound/csound/files/csound-5.17.11-cmake.patch
deleted file mode 100644
index 388a043d57cf..000000000000
--- a/media-sound/csound/files/csound-5.17.11-cmake.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
-+++ Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
-@@ -29,7 +29,6 @@
- allegrowr.cpp
- Cell.cpp
- ChordLindenmayer.cpp
-- cmake_install.cmake
- Composition.cpp
- Conversions.cpp
- Counterpoint.cpp
diff --git a/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch b/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
deleted file mode 100644
index ae07d41a63e3..000000000000
--- a/media-sound/csound/files/csound-5.17.11-no-fltk-gl.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
-+++ Csound5.17.11/frontends/CsoundAC/CMakeLists.txt
-@@ -7,6 +7,7 @@
-
- find_package(Boost)
- find_library(MUSICXML_LIBRARY musicxml2)
-+set(FLTK_SKIP_OPENGL true)
- find_package(FLTK)
- find_package(SWIG)
- find_package(PythonLibs)
---- Csound5.17.11/InOut/CMakeLists.txt
-+++ Csound5.17.11/InOut/CMakeLists.txt
-@@ -56,6 +56,7 @@
- find_library(COREAUDIO_LIBRARY CoreAudio)
- endif()
- if(USE_FLTK OR BUILD_VIRTUAL_KEYBOARD)
-+ set(FLTK_SKIP_OPENGL true)
- find_package(FLTK)
- endif()
-
diff --git a/media-sound/csound/files/csound-5.17.6-fltk.patch b/media-sound/csound/files/csound-5.17.6-fltk.patch
deleted file mode 100644
index 74b72689e889..000000000000
--- a/media-sound/csound/files/csound-5.17.6-fltk.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- Csound5.17.6/InOut/CMakeLists.txt
-+++ Csound5.17.6/InOut/CMakeLists.txt
-@@ -148,6 +148,7 @@
- if(USE_FLTK)
- set(widgets_SRCS FL_graph.cpp winFLTK.c widgets.cpp)
- make_plugin(widgets "${widgets_SRCS}" "${FLTK_LIBRARIES}")
-+ include_directories(${FLTK_INCLUDE_DIR})
- endif()
-
- check_deps(BUILD_VIRTUAL_KEYBOARD FLTK_FOUND)
diff --git a/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch b/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
deleted file mode 100644
index 3f69a3795f04..000000000000
--- a/media-sound/csound/files/csound-5.17.6-porttime-in-portmidi.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- Csound5.17.6/InOut/CMakeLists.txt
-+++ Csound5.17.6/InOut/CMakeLists.txt
-@@ -26,7 +26,6 @@
- endif()
- if(USE_PORTMIDI)
- find_library(PORTMIDI_LIBRARY portmidi)
-- find_library(PORTTIME_LIBRARY porttime)
- check_include_file(portmidi.h PORTMIDI_HEADER)
- endif()
- if(USE_JACK)
-@@ -116,9 +115,6 @@
- check_deps(USE_PORTMIDI PORTMIDI_HEADER PORTMIDI_LIBRARY)
- if(USE_PORTMIDI)
- set(pmidi_LIBS ${PORTMIDI_LIBRARY})
-- if(NOT APPLE)
-- list(APPEND pmidi_LIBS ${PORTTIME_LIBRARY})
-- endif()
- if(WIN32)
- list(APPEND pmidi_LIBS ${CSOUND_WINDOWS_LIBRARIES})
- endif()
diff --git a/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch b/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch
deleted file mode 100644
index 1ef67a15c13d..000000000000
--- a/media-sound/csound/files/csound-6.02-porttime-in-portmidi.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- Csound6.02/InOut/CMakeLists.txt
-+++ Csound6.02/InOut/CMakeLists.txt
-@@ -33,10 +33,6 @@
- find_library(PORTMIDI_LIBRARY portmidi)
- # include_directories(${PORTMIDI_INCLUDE_PATH})
- # include_directories(${PORTTIME_INCLUDE_PATH})
-- if(WIN32)
-- else()
-- find_library(PORTTIME_LIBRARY porttime)
-- endif()
- endif()
- if(USE_JACK)
- find_library(JACK_LIBRARY jack)
-@@ -126,15 +122,12 @@
- elseif(WIN32)
- check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTTIME_INCLUDE_PATH PORTMIDI_LIBRARY)
- else()
-- check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTMIDI_LIBRARY PORTTIME_LIBRARY)
-+ check_deps(USE_PORTMIDI PORTMIDI_INCLUDE_PATH PORTMIDI_LIBRARY)
- endif()
-
- if(USE_PORTMIDI)
- set(pmidi_LIBS ${PORTMIDI_LIBRARY})
- include_directories(${PORTMIDI_INCLUDE_PATH})
-- if(LINUX)
-- list(APPEND pmidi_LIBS ${PORTTIME_LIBRARY})
-- endif()
- if(WIN32)
- include_directories(${PORTTIME_INCLUDE_PATH})
- list(APPEND pmidi_LIBS ${CSOUND_WINDOWS_LIBRARIES})