summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-11-27 16:05:51 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-11-27 16:05:51 +0300
commitf6c373eb122810a19b5b38fffba210134da5b748 (patch)
treebccd0043b81756fb29908c75af9a20e9a08505cd /media-sound/csound/files
parentdev-util/catkin: include GNUInstallDirs in all.cmake so that LIBDIR is always... (diff)
downloadgentoo-f6c373eb122810a19b5b38fffba210134da5b748.tar.gz
gentoo-f6c373eb122810a19b5b38fffba210134da5b748.tar.bz2
gentoo-f6c373eb122810a19b5b38fffba210134da5b748.zip
media-sound/csound: fix underlinking on libm
Reported-by: Toralf Förster <toralf.foerster@gmx.de> Gentoo-Bug: 566064 Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound/csound/files')
-rw-r--r--media-sound/csound/files/csound-6.05-underlinking.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/csound/files/csound-6.05-underlinking.patch b/media-sound/csound/files/csound-6.05-underlinking.patch
new file mode 100644
index 000000000000..eac83f214190
--- /dev/null
+++ b/media-sound/csound/files/csound-6.05-underlinking.patch
@@ -0,0 +1,53 @@
+commit a4b1930b506274e328ee26cd6287965cb496062b
+Author: Steven Yi <stevenyi@gmail.com>
+Date: Mon Sep 28 18:21:22 2015 -0400
+
+ modified make_utility and targets for csound-bin and mixer-bin to use add libm for linking when on Linux [fixes #526]
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2b16079..18a6ad1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -97,6 +97,10 @@ endfunction(make_executable)
+ function(make_utility name srcs)
+ make_executable(${name} "${srcs}" "${CSOUNDLIB}")
+ add_dependencies(${name} ${CSOUNDLIB})
++
++ if(LINUX)
++ target_link_libraries(${name} m)
++ endif()
+ endfunction()
+
+
+diff --git a/frontends/CMakeLists.txt b/frontends/CMakeLists.txt
+index d0e3a21..b31f37a 100644
+--- a/frontends/CMakeLists.txt
++++ b/frontends/CMakeLists.txt
+@@ -43,6 +43,9 @@ endfunction(make_plugin_frontend)
+
+ # We need a different name to avoid clashes with float libcsound
+ make_executable(csound-bin "${CS_MAIN_SRCS}" "${CSOUNDLIB}" csound)
++if(LINUX)
++ target_link_libraries(csound-bin m)
++endif()
+
+ message(STATUS "Building csLadspa")
+
+diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
+index 25089cc..ebf0aa5 100644
+--- a/util/CMakeLists.txt
++++ b/util/CMakeLists.txt
+@@ -23,9 +23,11 @@ if(BUILD_UTILITIES)
+ make_utility(hetro het_main.c)
+ make_utility(lpanal lpc_main.c)
+ make_utility(lpc_export lpcx_main.c)
+- target_link_libraries(lpc_export m)
+ make_utility(lpc_import lpci_main.c)
+- make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
++ if(LINUX)
++ make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
++ endif()
++ target_link_libraries(mixer-bin m)
+ make_utility(pvanal pvc_main.c)
+ make_utility(pvlook pvl_main.c)
+ make_utility(pv_export pvx_main.c)