summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/dcd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/dcd')
-rw-r--r--media-sound/dcd/Manifest1
-rw-r--r--media-sound/dcd/dcd-0.95.ebuild30
-rw-r--r--media-sound/dcd/files/dcd-0.95-makefile.patch13
-rw-r--r--media-sound/dcd/metadata.xml5
4 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/dcd/Manifest b/media-sound/dcd/Manifest
new file mode 100644
index 000000000000..8e911ecc7143
--- /dev/null
+++ b/media-sound/dcd/Manifest
@@ -0,0 +1 @@
+DIST dcd-0.95.tar.bz2 33620 RMD160 3bb98d726e4a015766bc741d13b8ee74d3af5ed2 SHA1 61298fe7e9af3171fffa85daeaf8f528443f4b54 SHA256 6fc5b1e0b21fb299d52ea4d70d5a2c09172c3b939913d1b605afe8c48ca8bd41
diff --git a/media-sound/dcd/dcd-0.95.ebuild b/media-sound/dcd/dcd-0.95.ebuild
new file mode 100644
index 000000000000..7ea53a548cb7
--- /dev/null
+++ b/media-sound/dcd/dcd-0.95.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple command-line based CD Player"
+HOMEPAGE="http://www.technopagan.org/dcd"
+SRC_URI="http://www.technopagan.org/dcd/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CDROM="/dev/cdrom" EXTRA_CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin dcd || die "dobin failed"
+ doman dcd.1
+ dodoc README BUGS ChangeLog
+}
diff --git a/media-sound/dcd/files/dcd-0.95-makefile.patch b/media-sound/dcd/files/dcd-0.95-makefile.patch
new file mode 100644
index 000000000000..b59fedb6180c
--- /dev/null
+++ b/media-sound/dcd/files/dcd-0.95-makefile.patch
@@ -0,0 +1,13 @@
+Index: dcd-0.95/Makefile
+===================================================================
+--- dcd-0.95.orig/Makefile
++++ dcd-0.95/Makefile
+@@ -114,7 +114,7 @@ all: ${PROGS}
+ $(CC) -c $(CFLAGS) ${EXTRA_CFLAGS} $< -o $@
+
+ ${PROGS}: ${OBJECTS}
+- ${CC} ${CFLAGS} ${EXTRA_CFLAGS} ${OBJECTS} -o $@
++ ${CC} ${CFLAGS} ${LDFLAGS} ${EXTRA_CFLAGS} ${OBJECTS} -o $@
+
+ clean:;
+ -${RM} *.o ${PROGS}
diff --git a/media-sound/dcd/metadata.xml b/media-sound/dcd/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/dcd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>