summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/declick
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/declick')
-rw-r--r--media-sound/declick/Manifest1
-rw-r--r--media-sound/declick/declick-0.6.5.ebuild38
-rw-r--r--media-sound/declick/metadata.xml14
3 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/declick/Manifest b/media-sound/declick/Manifest
new file mode 100644
index 000000000000..227ddfc0ad52
--- /dev/null
+++ b/media-sound/declick/Manifest
@@ -0,0 +1 @@
+DIST declick-0.6.5.tar.gz 17932 SHA256 ce049078fd39ee68da9297cf0fa05ebce48c242934db8da1b87c2a6cdc985786
diff --git a/media-sound/declick/declick-0.6.5.ebuild b/media-sound/declick/declick-0.6.5.ebuild
new file mode 100644
index 000000000000..0a4ebe36a097
--- /dev/null
+++ b/media-sound/declick/declick-0.6.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="declick is a dynamic digital declicker for audio sample files"
+HOMEPAGE="http://home.snafu.de/wahlm/dl8hbs/declick.html"
+SRC_URI="http://home.snafu.de/wahlm/dl8hbs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+DEPEND=""
+
+src_prepare() {
+ # add $LDFLAGS to link command
+ sed -i -e "s:\(-o declick\):\$(LDFLAGS) \1:g" Makefile
+
+ # convert docs to utf-8
+ if [ -x "$(type -p iconv)" ]; then
+ for X in README; do
+ iconv -f LATIN1 -t UTF8 -o "${X}~" "${X}" && mv -f "${X}~" "${X}" || rm -f "${X}~"
+ done
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}" LDFLAGS="${LDFLAGS}" declick || die "emake failed"
+}
+
+src_install() {
+ dobin declick
+ dodoc README
+}
diff --git a/media-sound/declick/metadata.xml b/media-sound/declick/metadata.xml
new file mode 100644
index 000000000000..9ee4d5731cb4
--- /dev/null
+++ b/media-sound/declick/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ The main purpose of declick is the removal of digital clicks in the
+ input material. It is intended for the automatic removal of clicks
+ produced by scratched CDs or poorly working CD grabbers, for example
+ when using an IDE CD-ROM. It is not designed to remove analogue clicks
+ as from scratched LPs.
+ </longdescription>
+</pkgmetadata>