summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/flake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/flake')
-rw-r--r--media-sound/flake/Manifest1
-rw-r--r--media-sound/flake/flake-0.11.ebuild32
-rw-r--r--media-sound/flake/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/flake/Manifest b/media-sound/flake/Manifest
new file mode 100644
index 000000000000..a71bb16cf5cb
--- /dev/null
+++ b/media-sound/flake/Manifest
@@ -0,0 +1 @@
+DIST flake-0.11.tar.bz2 43319 SHA256 8dd249888005c2949cb4564f02b6badb34b2a0f408a7ec7ab01e11ceca1b7f19 SHA512 045cbe7f5af29dfdc5843df3dccfa6faf1ce816566b2f3ac928b98e14f5ee0ec15ee5024a092da4e33beb5d87c31f38c0780970811c5b96ae72683aeac332584 WHIRLPOOL 1ed1293f5db7606e3f2aa40f15fc066fdd17a85236b7ac1781f7c76c85f1c7e620d08e791836e2c07a93b4b1bd96c7b4e9392b4ae347d7c36478ec87fcc7459a
diff --git a/media-sound/flake/flake-0.11.ebuild b/media-sound/flake/flake-0.11.ebuild
new file mode 100644
index 000000000000..72d393af5b40
--- /dev/null
+++ b/media-sound/flake/flake-0.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="An alternative to the FLAC reference encoder"
+HOMEPAGE="http://flake-enc.sourceforge.net"
+SRC_URI="mirror://sourceforge/flake-enc/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+src_compile() {
+ local myconf
+
+ if ! use debug; then
+ myconf="${myconf} --disable-debug"
+ fi
+
+ ./configure --cc="$(tc-getCC)" --prefix="${D}"/usr \
+ --disable-opts --disable-strip ${myconf} || die "configure failed."
+
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake install || die "emake install failed."
+ dodoc Changelog README
+}
diff --git a/media-sound/flake/metadata.xml b/media-sound/flake/metadata.xml
new file mode 100644
index 000000000000..8364f22a83d2
--- /dev/null
+++ b/media-sound/flake/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">flake-enc</remote-id>
+ </upstream>
+</pkgmetadata>