summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-16 17:51:48 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-16 17:52:25 +0100
commit5b8fb13399e24aca92c35b82de0d94585263d2a4 (patch)
tree58cdd39afe0fc494b59390489ddfb79b40f14745 /media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch
parentdev-python/django-two-factor-auth: Dropped old version (diff)
downloadgentoo-5b8fb13399e24aca92c35b82de0d94585263d2a4.tar.gz
gentoo-5b8fb13399e24aca92c35b82de0d94585263d2a4.tar.bz2
gentoo-5b8fb13399e24aca92c35b82de0d94585263d2a4.zip
media-sound/gbsplay: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 571000 Also bump ebuild to EAPI=6. Fix -Werror=format-security errors. Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch')
-rw-r--r--media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch b/media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch
new file mode 100644
index 000000000000..82089f9553a5
--- /dev/null
+++ b/media-sound/gbsplay/files/gbsplay-0.0.91-fix-buildsystem.patch
@@ -0,0 +1,32 @@
+Fix linking failure due to different GCC5 inline semantics
+https://bugs.gentoo.org/show_bug.cgi?id=571000
+
+In addition, fix QA warnings caused by passing
+an unformatted string to printf().
+
+--- gbsplay-0.0.91/Makefile
++++ gbsplay-0.0.91/Makefile
+@@ -35,7 +35,7 @@
+ -predboolothers \
+ -shiftnegative \
+ -shiftimplementation
+-GBSCFLAGS := -Wall -fsigned-char -D_FORTIFY_SOURCE=2
++GBSCFLAGS := -Wall -fsigned-char -std=gnu89
+ GBSLDFLAGS := -Wl,-O1 -lm
+ GBSPLAYLDFLAGS :=
+
+--- gbsplay-0.0.91/plugout.c
++++ gbsplay-0.0.91/plugout.c
+@@ -55,10 +55,10 @@
+ {
+ long idx;
+
+- printf(_("Available output plugins:\n\n"));
++ fputs(_("Available output plugins:\n\n"), stdout);
+
+ if (plugouts[0] == NULL) {
+- printf(_("No output plugins available.\n\n"));
++ fputs(_("No output plugins available.\n\n"), stdout);
+ return;
+ }
+