summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-30 10:28:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-30 10:38:27 +0200
commit305ae9305fa3ffde1ef8ed0141acccce24f280a6 (patch)
treed5dd800fc1254aa2ef54a7867960420f7093bde2 /media-sound/glmix
parentdev-libs/libuv: remove ltprune eclass (diff)
downloadgentoo-305ae9305fa3ffde1ef8ed0141acccce24f280a6.tar.gz
gentoo-305ae9305fa3ffde1ef8ed0141acccce24f280a6.tar.bz2
gentoo-305ae9305fa3ffde1ef8ed0141acccce24f280a6.zip
media-sound/glmix: EAPI7 bump, https, description
Thanks-to: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://bugs.gentoo.org/666888 Closes: https://github.com/gentoo/gentoo/pull/9957 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/glmix')
-rw-r--r--media-sound/glmix/glmix-0.3.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/media-sound/glmix/glmix-0.3.ebuild b/media-sound/glmix/glmix-0.3.ebuild
index fa4e7709de08..b2b43f2ec366 100644
--- a/media-sound/glmix/glmix-0.3.ebuild
+++ b/media-sound/glmix/glmix-0.3.ebuild
@@ -1,30 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=7
-inherit eutils toolchain-funcs
+inherit desktop toolchain-funcs
-DESCRIPTION="A 3D widget for mixing up to eight JACK audio streams down to stereo"
-HOMEPAGE="http://devel.tlrmx.org/audio"
-SRC_URI="http://devel.tlrmx.org/audio/source/${P}.tar.gz"
+DESCRIPTION="3D widget for mixing up to eight JACK audio streams down to stereo"
+HOMEPAGE="https://devel.tlrmx.org/audio"
+SRC_URI="https://devel.tlrmx.org/audio/source/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="media-sound/jack-audio-connection-kit
+RDEPEND="
+ media-sound/jack-audio-connection-kit
+ x11-libs/gtk+:2
>=x11-libs/gtkglext-1
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
local libs="gtk+-2.0 gtkglext-1.0 jack pango"
emake CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} $(pkg-config --cflags ${libs})" \
- LDFLAGS="-lm ${LDFLAGS} $(pkg-config --libs ${libs})" || die "emake failed."
+ LDFLAGS="-lm ${LDFLAGS} $(pkg-config --libs ${libs})"
}
src_install() {