summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gramofile/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gramofile/files')
-rw-r--r--media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch56
-rw-r--r--media-sound/gramofile/files/gramofile-1.6_p9-gentoo.patch39
-rw-r--r--media-sound/gramofile/files/gramofile-1.6_p9-strlen_and_exit.patch20
3 files changed, 115 insertions, 0 deletions
diff --git a/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
new file mode 100644
index 000000000000..4c35dd3eb2ff
--- /dev/null
+++ b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
@@ -0,0 +1,56 @@
+--- a/bplaysrc/Makefile
++++ b/bplaysrc/Makefile
+@@ -6,13 +6,12 @@
+ ../clrscr.o ../secshms.o
+ #SRCS = bplay.c sndfunc.o shmbuf.c
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DLP2CD -DVUMETER # -DDEBUG
++CFLAGS += -Wall -DUSEBUFFLOCK -DLP2CD -DVUMETER
+ LIBS = -lncurses
+
+ # For FreeBSD (and maybe others), use these:
+--- a/gramofile.c
++++ b/gramofile.c
+@@ -11,6 +11,7 @@
+ #include "splashscr.h"
+ #include <signal.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+--- a/Makefile
++++ b/Makefile
+@@ -14,13 +14,12 @@
+ OBJS = $(SRCS:.c=.o)
+ SHELL = /bin/sh
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
++CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER
+ DEPS = $(OBJS) makebplay
+ LIBS = -lncurses -lrfftw -lfftw -lm
+ COPY_A = -a
+--- a/signpr_cmf3.c
++++ b/signpr_cmf3.c
+@@ -34,6 +34,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
diff --git a/media-sound/gramofile/files/gramofile-1.6_p9-gentoo.patch b/media-sound/gramofile/files/gramofile-1.6_p9-gentoo.patch
new file mode 100644
index 000000000000..9fdbe1477233
--- /dev/null
+++ b/media-sound/gramofile/files/gramofile-1.6_p9-gentoo.patch
@@ -0,0 +1,39 @@
+--- a/Makefile
++++ b/Makefile
+@@ -14,15 +14,12 @@
+ OBJS = $(SRCS:.c=.o)
+ SHELL = /bin/sh
+
+-CC = gcc
+-LDFLAGS =
+-
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
++CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER
+ DEPS = $(OBJS) makebplay
+-LIBS = -lncurses -lrfftw -lfftw -lm
++LIBS = $(shell ${PKG_CONFIG} --libs ncurses) -lrfftw -lfftw -lm
+ COPY_A = -a
+
+ # For FreeBSD (and maybe others), use these:
+--- a/bplaysrc/Makefile
++++ b/bplaysrc/Makefile
+@@ -6,14 +6,11 @@
+ ../clrscr.o ../secshms.o
+ #SRCS = bplay.c sndfunc.o shmbuf.c
+
+-CC = gcc
+-LDFLAGS =
+-
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DLP2CD -DVUMETER # -DDEBUG
+-LIBS = -lncurses
++CFLAGS += -Wall -DUSEBUFFLOCK -DLP2CD -DVUMETER # -DDEBUG
++LIBS = $(shell ${PKG_CONFIG} --libs ncurses)
+
+ # For FreeBSD (and maybe others), use these:
+ #CFLAGS = -Wall -O2 -DLP2CD -DVUMETER # -DDEBUG
diff --git a/media-sound/gramofile/files/gramofile-1.6_p9-strlen_and_exit.patch b/media-sound/gramofile/files/gramofile-1.6_p9-strlen_and_exit.patch
new file mode 100644
index 000000000000..0369914779fd
--- /dev/null
+++ b/media-sound/gramofile/files/gramofile-1.6_p9-strlen_and_exit.patch
@@ -0,0 +1,20 @@
+--- a/gramofile.c
++++ b/gramofile.c
+@@ -11,6 +11,7 @@
+ #include "splashscr.h"
+ #include <signal.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+--- a/signpr_cmf3.c
++++ b/signpr_cmf3.c
+@@ -33,6 +33,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else