summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 13:38:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 13:39:01 +0100
commit5f2154fd4b0865143496b375f1e23b3fb5ff11f2 (patch)
tree0bd25a4d58e6ffdecdfd0f9f67eae493504676bf /media-sound/hydrogen
parentx11-terms/qterminal: EAPI-7 bump (diff)
downloadgentoo-5f2154fd4b0865143496b375f1e23b3fb5ff11f2.tar.gz
gentoo-5f2154fd4b0865143496b375f1e23b3fb5ff11f2.tar.bz2
gentoo-5f2154fd4b0865143496b375f1e23b3fb5ff11f2.zip
media-sound/hydrogen: EAPI-7 bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/hydrogen')
-rw-r--r--media-sound/hydrogen/hydrogen-9999.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/media-sound/hydrogen/hydrogen-9999.ebuild b/media-sound/hydrogen/hydrogen-9999.ebuild
index 2d92d83a64cb..5bcfaa020fec 100644
--- a/media-sound/hydrogen/hydrogen-9999.ebuild
+++ b/media-sound/hydrogen/hydrogen-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3 xdg-utils
+inherit git-r3 xdg cmake-utils
DESCRIPTION="Advanced drum machine"
HOMEPAGE="http://www.hydrogen-music.org/"
@@ -16,7 +16,12 @@ IUSE="alsa +archive doc jack ladspa lash osc oss portaudio portmidi pulseaudio"
REQUIRED_USE="lash? ( alsa )"
-RDEPEND="
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
@@ -34,10 +39,7 @@ RDEPEND="
portmidi? ( media-libs/portmidi )
pulseaudio? ( media-sound/pulseaudio )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
+RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog DEVELOPERS README.txt )
@@ -71,16 +73,6 @@ src_compile() {
}
src_install() {
- use doc && local HTML_DOCS=( ${BUILD_DIR}/docs/html/. )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
cmake-utils_src_install
}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}