summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/kradio/kradio-4.0.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/kradio/kradio-4.0.8.ebuild')
-rw-r--r--media-sound/kradio/kradio-4.0.8.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/kradio/kradio-4.0.8.ebuild b/media-sound/kradio/kradio-4.0.8.ebuild
new file mode 100644
index 000000000000..6d4c7ebf9bd8
--- /dev/null
+++ b/media-sound/kradio/kradio-4.0.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS_DIR=( po convert-presets/po )
+PLUGINS=(
+ alsa-sound dbus gui-docking-menu gui-error-log gui-quickbar
+ gui-standard-display internetradio lirc oss-sound radio recording shortcuts
+ soundserver streaming timecontrol timeshifter v4lradio
+)
+KDE_LINGUAS="cs de es is it pl pt pt_BR ru sk tr uk"
+inherit kde4-base
+
+MY_P=${PN}4-${PV/_/-}
+
+DESCRIPTION="kradio is a radio tuner application for KDE"
+HOMEPAGE="http://kradio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="alsa debug encode ffmpeg lirc +mp3 +vorbis v4l"
+
+DEPEND="
+ media-libs/libsndfile
+ alsa? ( media-libs/alsa-lib )
+ ffmpeg? (
+ >=media-libs/libmms-0.4
+ virtual/ffmpeg
+ )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-sound/lame )
+ vorbis? (
+ media-libs/libvorbis
+ media-libs/libogg
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-4.0.7-include.patch" )
+
+src_prepare() {
+ local lang
+ for lang in ${KDE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ for dir in "${KDE_LINGUAS_DIR[@]}" ; do
+ rm ${dir}/${lang}.po
+ done
+ for plugin in "${PLUGINS[@]}" ; do
+ rm plugins/${plugin}/po/${lang}.po
+ done
+ fi
+ done
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with ffmpeg)
+ $(cmake-utils_use_with lirc)
+ $(cmake-utils_use_with mp3 LAME)
+ $(cmake-utils_use_with vorbis OGG_VORBIS)
+ $(cmake-utils_use_with v4l V4L2)
+ )
+
+ kde4-base_src_configure
+}