summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-03-18 10:55:45 +0100
committerJohannes Huber <johu@gentoo.org>2020-03-18 10:56:35 +0100
commit140efe6d2278901177fc9f3bb5b96b6b7974f534 (patch)
treeebf0f598656c5034593c4b2e5fe9c4e368188bfc /media-sound/lollypop
parentdev-python/pyopenssl: ia64 stable wrt bug #713114 (diff)
downloadgentoo-140efe6d2278901177fc9f3bb5b96b6b7974f534.tar.gz
gentoo-140efe6d2278901177fc9f3bb5b96b6b7974f534.tar.bz2
gentoo-140efe6d2278901177fc9f3bb5b96b6b7974f534.zip
media-sound/lollypop: Version bump 1.2.25
Closes: https://bugs.gentoo.org/710238 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.25.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 5510b4760f98..b91f4966c277 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
DIST lollypop-1.2.22.tar.xz 492964 BLAKE2B b113d5e19ec63a5535c86e2347b49c3fe4f56dabdfc4c7943ce956931580cdd92e96cb35c5c45c84d75f2d599e78c93caa195216a1a754f764254e4b73ccb531 SHA512 0161be7d6d2a10db57679c4c230ab9832ab34ce7074fc9e215a56a0dcc64fe17b3b8367c271209a75096b327dd6b793be2f54fb3904e3c98a26b1cd2aa88962b
+DIST lollypop-1.2.25.tar.xz 501864 BLAKE2B de009282359ac6b030f567417fa2e159fd5803d6395e77270a1b671f507f61ac7fad76e29b1ebb1ad75de68d2f07b44b4d0878deb9195a9a2d6934501a3a2a64 SHA512 7ffedff3b3b40c158db83368af77025884576693202917cc74916edb5182b942387ab8a13dcc37f24e7096256f2c676c268d0dda996450d916605ffd4ac1ff41
diff --git a/media-sound/lollypop/lollypop-1.2.25.ebuild b/media-sound/lollypop/lollypop-1.2.25.ebuild
new file mode 100644
index 000000000000..06db306eb32f
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.25.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo(+)]
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}