summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-04-04 18:43:22 +0200
committerJohannes Huber <johu@gentoo.org>2020-04-04 18:44:18 +0200
commit3c4c718f7f97d4e3ee3ad9541dd227ed13f7183b (patch)
treef981c9c986871395a84c4ac701448745b553c6f2 /media-sound/lollypop
parentdev-vcs/cli: sync live (diff)
downloadgentoo-3c4c718f7f97d4e3ee3ad9541dd227ed13f7183b.tar.gz
gentoo-3c4c718f7f97d4e3ee3ad9541dd227ed13f7183b.tar.bz2
gentoo-3c4c718f7f97d4e3ee3ad9541dd227ed13f7183b.zip
media-sound/lollypop: Version bump 1.2.33
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.33.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 019ee752797e..bd80bbc6aeec 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
DIST lollypop-1.2.32.tar.xz 504544 BLAKE2B ba93daa5d52d43401454c7c5e9fb05f2ef2d1d22de49da5d404120de0f6c41522a00c055fd190a5fe3a296174641773a322fab5548aceedee559987fac2ffd81 SHA512 08a4012ad252dcd6371479759547b082bcc12de0a76fc365519234e0d77dccc505cf264a352a3963cea722ce2820ea7a3521d23ab03d4695b95d88e678528c7b
+DIST lollypop-1.2.33.tar.xz 509636 BLAKE2B 850f24e14cd574710f0712389a1db96380eb1058fbb76e0353d9f6aa66978754bd30e4584fd3f50724909796247ec894c8f0c0b1cb1476ed0935596a0edcefe6 SHA512 f5e77e7427f1ef4db05f8ffc1f0f2fd3c412ea22b433a7b0a9de7e0159b0172012478dfb2cd1a39df27c07bcd1dd55fdb14a430d9cf8b04aa77ff7befc92c95b
diff --git a/media-sound/lollypop/lollypop-1.2.33.ebuild b/media-sound/lollypop/lollypop-1.2.33.ebuild
new file mode 100644
index 000000000000..06db306eb32f
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.33.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo(+)]
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}