summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-10-26 12:57:55 +0200
committerJohannes Huber <johu@gentoo.org>2019-10-26 12:58:28 +0200
commit69d2a75ba88228d2c416467fe8a06d6c28442a8b (patch)
treebc6c3fbef03d810f3b5c517c273a2878a33366bf /media-sound/lollypop
parentkde-plasma/drkonqi: Disable connectiontest, needs network access (diff)
downloadgentoo-69d2a75ba88228d2c416467fe8a06d6c28442a8b.tar.gz
gentoo-69d2a75ba88228d2c416467fe8a06d6c28442a8b.tar.bz2
gentoo-69d2a75ba88228d2c416467fe8a06d6c28442a8b.zip
media-sound/lollypop: Version bump 1.2.2
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index d21bc3d876db..125a44203b50 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.0.12.tar.xz 448864 BLAKE2B 65681bc29f8256ad8f9d6dadac7a6d147150a8f779e25c85744a39428176c6887e3a9f90f0af81f432db771806351301712ec2431c3a79bcb230c8c0e6fb055b SHA512 d6ad6fb638ac994c2c0367234c8ab35b79d619b3669c46f27bc1df221e41410f464a0a157faccf0ed1b2b5fbdb9f1ecad10ec7466bdff03231e4724948c8c3a2
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
+DIST lollypop-1.2.2.tar.xz 478792 BLAKE2B dbd68faeea0c6bed042c16c4851e787de17b032a00915cea33f039e217db3e0364b434eae7c6eadd47dc556992f91b8604ea42a9c3cab0fb9014827ef9fc480b SHA512 3dd335ea217159985d78b4e521022b5008bc27c12ee83f79e0516d65f92078ef4dea9beac9f15e2ad2c76ccaa4b8520ecb24a1394c9c4e7fb916d9d8b3943812
diff --git a/media-sound/lollypop/lollypop-1.2.2.ebuild b/media-sound/lollypop/lollypop-1.2.2.ebuild
new file mode 100644
index 000000000000..138068d27cd6
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="aa4fbd92bf338296c28e54710271ccab"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}