summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-06 21:54:31 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-06 22:01:52 +0100
commitdc2df8094201dddee871f1fb90859ee3338069de (patch)
tree30f240a49bb5d972698519ccbf022fd48c34e2af /media-sound/lollypop
parentsys-libs/compiler-rt-sanitizers: Fix Python branches more (diff)
downloadgentoo-dc2df8094201dddee871f1fb90859ee3338069de.tar.gz
gentoo-dc2df8094201dddee871f1fb90859ee3338069de.tar.bz2
gentoo-dc2df8094201dddee871f1fb90859ee3338069de.zip
media-sound/lollypop: Version bump 1.2.19
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.19.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index e2212885a101..8e94122b0ae3 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
DIST lollypop-1.2.16.tar.xz 484704 BLAKE2B fd6c37690301eff22b52865df1e2d65108c0a25c3ff08d0960e5b09213cb21b2af62886e6cbcaff051a01c5084129dbe38832ac25ff4bb9a60d00566e60e7d38 SHA512 5912f7b09ec166f9680815293be3e7b3cc9ceedc9e12156715b908f4905ee937afb7eecc2b32c70108cfdac4a06abe450415b7c90e6a3e3ef641a1f846ef39e2
+DIST lollypop-1.2.19.tar.xz 483188 BLAKE2B 3c727878b90c8c48505becb47575d295c7623a086ab965def468554c385b956fd346ec22b460fa74964231e04d1310af93b286c6896b34e90104386b8d768536 SHA512 ef73fd592e2375456099365b429b04d5239d913f0c7e7f969b8d06352de8d4f8b8580ea1f0f43a5a0ca420324873c78e48d4f35cc791514b18461a744ecbcd02
diff --git a/media-sound/lollypop/lollypop-1.2.19.ebuild b/media-sound/lollypop/lollypop-1.2.19.ebuild
new file mode 100644
index 000000000000..fe1a81740e3c
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.19.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="5918e6040337c71b8b88932301c7de0e"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_foreach_impl python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}