summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/marrie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/marrie')
-rw-r--r--media-sound/marrie/Manifest1
-rw-r--r--media-sound/marrie/marrie-0.3.2-r1.ebuild58
-rw-r--r--media-sound/marrie/marrie-9999.ebuild58
-rw-r--r--media-sound/marrie/metadata.xml17
4 files changed, 134 insertions, 0 deletions
diff --git a/media-sound/marrie/Manifest b/media-sound/marrie/Manifest
new file mode 100644
index 000000000000..cfc1d0028d11
--- /dev/null
+++ b/media-sound/marrie/Manifest
@@ -0,0 +1 @@
+DIST marrie-0.3.2.tar.gz 7626 SHA256 be65ca0f2a238ec811d778db938d98488f72a8df2d323fed0a7730f3b7e29258 SHA512 da6688e18124f2c95e2dd9846a2578fd2e6312f7e145424f50761eaabdd3c234424921f289b595e8842a9f5e3863a9ef106331c19cec42de9731d12f9584958a WHIRLPOOL 33f7b0681d6290f0eddfb1117c89283551d4299a05adfbdc4fbae5bdbccec6e00040ff22000becefce9be1930675291ade2cc1925b7234fe599d4dc5c95cc7a7
diff --git a/media-sound/marrie/marrie-0.3.2-r1.ebuild b/media-sound/marrie/marrie-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..04d9d26810d9
--- /dev/null
+++ b/media-sound/marrie/marrie-0.3.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+GIT_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="git://github.com/rafaelmartins/marrie.git
+ https://github.com/rafaelmartins/marrie.git"
+fi
+
+inherit distutils-r1 ${GIT_ECLASS}
+
+DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
+HOMEPAGE="https://github.com/rafaelmartins/marrie"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/setuptools
+ >=dev-python/feedparser-5.1.3"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ rst2html.py README.rst marrie.html || die "rst2html.py failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ if use doc; then
+ dohtml marrie.html
+ fi
+}
+
+pkg_postinst() {
+ distutils-r1_pkg_postinst
+ elog
+ elog "You'll need a media player and a file downloader."
+ elog "Recommended packages: net-misc/wget and media-video/mplayer"
+ elog
+}
diff --git a/media-sound/marrie/marrie-9999.ebuild b/media-sound/marrie/marrie-9999.ebuild
new file mode 100644
index 000000000000..04d9d26810d9
--- /dev/null
+++ b/media-sound/marrie/marrie-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+GIT_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="git://github.com/rafaelmartins/marrie.git
+ https://github.com/rafaelmartins/marrie.git"
+fi
+
+inherit distutils-r1 ${GIT_ECLASS}
+
+DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
+HOMEPAGE="https://github.com/rafaelmartins/marrie"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/setuptools
+ >=dev-python/feedparser-5.1.3"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ rst2html.py README.rst marrie.html || die "rst2html.py failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ if use doc; then
+ dohtml marrie.html
+ fi
+}
+
+pkg_postinst() {
+ distutils-r1_pkg_postinst
+ elog
+ elog "You'll need a media player and a file downloader."
+ elog "Recommended packages: net-misc/wget and media-video/mplayer"
+ elog
+}
diff --git a/media-sound/marrie/metadata.xml b/media-sound/marrie/metadata.xml
new file mode 100644
index 000000000000..cf524c19040d
--- /dev/null
+++ b/media-sound/marrie/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>rafael@rafaelmartins.eng.br</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <bugs-to>mailto:rafael@rafaelmartins.eng.br</bugs-to>
+ <remote-id type="pypi">marrie</remote-id>
+ <remote-id type="github">rafaelmartins/marrie</remote-id>
+ </upstream>
+</pkgmetadata>