summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild')
-rw-r--r--media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild b/media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild
new file mode 100644
index 000000000000..cba4b58583f8
--- /dev/null
+++ b/media-sound/mhwaveedit/mhwaveedit-1.4.23.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="GTK+ Sound file editor (wav, and a few others.)"
+HOMEPAGE="https://gna.org/projects/mhwaveedit"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa jack ladspa libsamplerate nls oss pulseaudio sdl sndfile sox"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/pango
+ sndfile? ( >=media-libs/libsndfile-1.0.10 )
+ sdl? ( >=media-libs/libsdl-1.2.3 )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? ( media-libs/libsamplerate )
+ ladspa? ( media-libs/ladspa-sdk )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.10 )
+ sox? ( media-sound/sox )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+
+src_configure() {
+ econf \
+ --without-arts \
+ --without-portaudio \
+ $(use_enable nls) \
+ $(use_with sndfile libsndfile) \
+ $(use_with libsamplerate) \
+ $(use_with sdl) \
+ $(use_with alsa alsalib) \
+ $(use_with oss) \
+ $(use_with jack) \
+ $(use_with pulseaudio pulse) \
+ --without-esound
+}