summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:13:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 15:30:50 +0100
commit9587e4463685465b87d12026397e84586a109838 (patch)
tree34a109347eb6bfb6eda3c8e9e1768ff449e356bc /media-sound/milkytracker
parentapp-dicts/myspell-nl: sparc stable wrt bug #704350 (diff)
downloadgentoo-9587e4463685465b87d12026397e84586a109838.tar.gz
gentoo-9587e4463685465b87d12026397e84586a109838.tar.bz2
gentoo-9587e4463685465b87d12026397e84586a109838.zip
*/*: Switch sound proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/milkytracker')
-rw-r--r--media-sound/milkytracker/milkytracker-1.0.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/media-sound/milkytracker/milkytracker-1.0.0.ebuild b/media-sound/milkytracker/milkytracker-1.0.0.ebuild
index f2fac2cf6422..3d5f9f04861d 100644
--- a/media-sound/milkytracker/milkytracker-1.0.0.ebuild
+++ b/media-sound/milkytracker/milkytracker-1.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop
+inherit cmake desktop
DESCRIPTION="FastTracker 2 inspired music tracker"
HOMEPAGE="https://milkytracker.titandemo.org/"
@@ -31,15 +31,14 @@ S="${WORKDIR}/MilkyTracker-${PV}"
src_configure() {
local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
- $(cmake-utils_use_find_package alsa ALSA)
- $(cmake-utils_use_find_package jack JACK)
+ $(cmake_use_find_package alsa ALSA)
+ $(cmake_use_find_package jack JACK)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newicon resources/pictures/carton.png ${PN}.png
make_desktop_entry ${PN} MilkyTracker ${PN} \