summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mimd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mimd')
-rw-r--r--media-sound/mimd/Manifest1
-rw-r--r--media-sound/mimd/files/mimd-0.30.1+live-2006.12.08.patch29
-rw-r--r--media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch12
-rw-r--r--media-sound/mimd/metadata.xml5
-rw-r--r--media-sound/mimd/mimd-0.30.1.ebuild59
5 files changed, 106 insertions, 0 deletions
diff --git a/media-sound/mimd/Manifest b/media-sound/mimd/Manifest
new file mode 100644
index 000000000000..08f2e6383318
--- /dev/null
+++ b/media-sound/mimd/Manifest
@@ -0,0 +1 @@
+DIST mimd-0.30.1.tar.bz2 16853 SHA256 c1ee0c19163b412dede0cf7d302050931498f2d34fe2e1e9c580d609c8c91924
diff --git a/media-sound/mimd/files/mimd-0.30.1+live-2006.12.08.patch b/media-sound/mimd/files/mimd-0.30.1+live-2006.12.08.patch
new file mode 100644
index 000000000000..96b94095e349
--- /dev/null
+++ b/media-sound/mimd/files/mimd-0.30.1+live-2006.12.08.patch
@@ -0,0 +1,29 @@
+Index: mimd-0.30.1/Makefile.in
+===================================================================
+--- mimd-0.30.1.orig/Makefile.in
++++ mimd-0.30.1/Makefile.in
+@@ -1,10 +1,12 @@
+ LIVEDIR=@LIVEDIR@
+-XERCESDIR=@XERCESDIR@
++#XERCESDIR=@XERCESDIR@
++XERCESDIR=/usr
+ PREFIX=@PREFIX@
+
+-CXXFLAGS += -I$(LIVEDIR)/BasicUsageEnvironment/include -I$(LIVEDIR)/groupsock/include -I$(LIVEDIR)/liveMedia/include -I$(LIVEDIR)/UsageEnvironment/include -I$(XERCESDIR)/include -Isrc/include -DVERSION="0301"
++#CXXFLAGS += -I$(LIVEDIR)/BasicUsageEnvironment/include -I$(LIVEDIR)/groupsock/include -I$(LIVEDIR)/liveMedia/include -I$(LIVEDIR)/UsageEnvironment/include -I$(XERCESDIR)/include -Isrc/include -DVERSION="0301"
++CPPFLAGS += -I/usr/include/BasicUsageEnvironment -I/usr/include/groupsock -I/usr/include/liveMedia -I/usr/include/UsageEnvironment -Isrc/include -DVERSION="0301"
+
+-LDFLAGS=-L$(LIVEDIR)/BasicUsageEnvironment -L$(LIVEDIR)/groupsock -L$(LIVEDIR)/liveMedia -L$(LIVEDIR)/UsageEnvironment -L$(XERCESDIR)/lib
++#LDFLAGS=-L$(LIVEDIR)/BasicUsageEnvironment -L$(LIVEDIR)/groupsock -L$(LIVEDIR)/liveMedia -L$(LIVEDIR)/UsageEnvironment -L$(XERCESDIR)/lib
+
+ LDLIBS=-lxerces-c -lUsageEnvironment -lBasicUsageEnvironment -lgroupsock -lliveMedia -lpthread
+
+@@ -32,7 +34,7 @@ OBJS= src/MediaStreamer.o\
+ src/parser.o
+
+ mimd: $(OBJS)
+- g++ -o mimd $(LDFLAGS) $(OBJS) $(LDLIBS)
++ $(CXX) -o mimd $(LDFLAGS) $(OBJS) $(LDLIBS)
+
+ install: mimd
+ mkdir -p $(PREFIX)/doc $(PREFIX)/etc $(PREFIX)/bin $(PREFIX)/man/man1 > /dev/null
diff --git a/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch b/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch
new file mode 100644
index 000000000000..74a1e76560b1
--- /dev/null
+++ b/media-sound/mimd/files/mimd-0.30.1-fortify_sources.patch
@@ -0,0 +1,12 @@
+diff -ur mimd-0.30.1.orig/src/parser.cpp mimd-0.30.1/src/parser.cpp
+--- mimd-0.30.1.orig/src/parser.cpp 2003-07-10 21:35:52.000000000 +0300
++++ mimd-0.30.1/src/parser.cpp 2009-06-06 19:49:56.000000000 +0300
+@@ -37,7 +37,7 @@
+ int fd;
+
+ // Check to see if we can make a scratch file in the directory
+- if((fd=open(tf.c_str(), O_RDWR|O_CREAT|O_TRUNC)) == -1)
++ if((fd=open(tf.c_str(), O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR)) == -1)
+ return false;
+
+ // Close and delete the test file
diff --git a/media-sound/mimd/metadata.xml b/media-sound/mimd/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/mimd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/mimd/mimd-0.30.1.ebuild b/media-sound/mimd/mimd-0.30.1.ebuild
new file mode 100644
index 000000000000..ca7a3efe069b
--- /dev/null
+++ b/media-sound/mimd/mimd-0.30.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Multicast streaming server for MPEG1/2 and MP3 files"
+HOMEPAGE="http://darkwing.uoregon.edu/~tkay/mim.html"
+SRC_URI="http://darkwing.uoregon.edu/~tkay/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+RDEPEND=">=media-plugins/live-2006.12.08
+ dev-libs/xerces-c"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+live-2006.12.08.patch \
+ "${FILESDIR}"/${P}-fortify_sources.patch
+ cp -f Makefile.in Makefile
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin mimd || die "dobin failed"
+ dodoc doc/mimd.pod
+
+ if [ -x /usr/bin/pod2html ]; then
+ pod2html < doc/mimd.pod > doc/mimd.html
+ dohtml doc/mimd.html
+ fi
+
+ if [ -x /usr/bin/pod2man ]; then
+ pod2man < doc/mimd.pod > doc/mimd.1
+ doman doc/mimd.1
+ fi
+
+ insinto /usr/share/mimd
+ doins etc/mimd.dtd etc/sample.xml
+}
+
+pkg_postinst() {
+ elog "Please read the documentation (mimd.html or man mimd) for "
+ elog "instructions on configuring mimd. The DTD for the configuration "
+ elog "files is in /usr/share/mimd/mimd.dtd, along with a sample "
+ elog "configuration file (/usr/share/mimd/sample.xml)."
+ ewarn "NOTE: You must have ip multicasting enabled in the kernel for this"
+ ewarn "daemon to work properly."
+}