summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-21 23:54:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-22 18:05:52 +0200
commiteb8c6b43e5155ea943eb9a1ec52d3d40d3776b1c (patch)
tree4595464cbe1de53a18d46e42effd6b4ea50b12f0 /media-sound/mp3cat
parentmedia-sound/mhwaveedit: Drop 1.4.23 (diff)
downloadgentoo-eb8c6b43e5155ea943eb9a1ec52d3d40d3776b1c.tar.gz
gentoo-eb8c6b43e5155ea943eb9a1ec52d3d40d3776b1c.tar.bz2
gentoo-eb8c6b43e5155ea943eb9a1ec52d3d40d3776b1c.zip
media-sound/mp3cat: 0.5 version bump, EAPI-7 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/mp3cat')
-rw-r--r--media-sound/mp3cat/Manifest1
-rw-r--r--media-sound/mp3cat/mp3cat-0.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/mp3cat/Manifest b/media-sound/mp3cat/Manifest
index 82855e1e4033..6069eb8cc0bb 100644
--- a/media-sound/mp3cat/Manifest
+++ b/media-sound/mp3cat/Manifest
@@ -1 +1,2 @@
DIST mp3cat-0.4.tar.gz 14956 BLAKE2B 3da17f7ccd5739657ebfa31fbc78a77f78d7b25fd3e1e82825fa2efc677b2aa64da8f699faaef8dd55ecea647bcfa014c7bc6149a9ca52b1f255304f838837e9 SHA512 a72bbbd296bb07a7e7fc084a494b2676c012cf3a4c71ace7eea52892f6f478769c5b6140fcd8dbfa245d537335a484fd8c5db15edd83a0146821d48e24862492
+DIST mp3cat-0.5.tar.gz 15711 BLAKE2B c2b6c0e3d0dc96ac3a3356b735909f4a8dda596b6d71e97aafd62fa65c34d382c4855c8676d36044bd08b8e4ff7aad4a2d7ababf014546861ddf9f22b09a35cb SHA512 084a0640d1a9870c5fd6a5378565598c747245e0489a7d34c299a226cf5b08a2150b1f89ed5b02a0193af480487a7c3d659382af7d9fc08db2167a9541804ee1
diff --git a/media-sound/mp3cat/mp3cat-0.5.ebuild b/media-sound/mp3cat/mp3cat-0.5.ebuild
new file mode 100644
index 000000000000..f12a8af66ec2
--- /dev/null
+++ b/media-sound/mp3cat/mp3cat-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Reads and writes MP3 files"
+HOMEPAGE="https://tomclegg.ca/mp3cat"
+SRC_URI="https://github.com/tomclegg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ sed -i -e 's:cc -o:${CC} ${CFLAGS} ${LDFLAGS} -o:' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin mp3cat mp3log mp3log-conf mp3dirclean mp3http mp3stream-conf
+}