summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-21 16:34:19 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-21 16:37:51 +0200
commitd3251f82484c3f9b488a3f1fa1d87f9e0172cdbd (patch)
treeafb93b4ba057ce5640d65a5e8678f3ecf5066689 /media-sound/mp3gain/mp3gain-1.6.1.ebuild
parentsys-devel/clang-runtime: bump SLOT to 6.0.1 (diff)
downloadgentoo-d3251f82484c3f9b488a3f1fa1d87f9e0172cdbd.tar.gz
gentoo-d3251f82484c3f9b488a3f1fa1d87f9e0172cdbd.tar.bz2
gentoo-d3251f82484c3f9b488a3f1fa1d87f9e0172cdbd.zip
media-sound/mp3gain: Bump (#630954), fix CVE-2017-12911 (#635548)
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'media-sound/mp3gain/mp3gain-1.6.1.ebuild')
-rw-r--r--media-sound/mp3gain/mp3gain-1.6.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/mp3gain/mp3gain-1.6.1.ebuild b/media-sound/mp3gain/mp3gain-1.6.1.ebuild
new file mode 100644
index 000000000000..81548cbb0e12
--- /dev/null
+++ b/media-sound/mp3gain/mp3gain-1.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_P="${P//./_}"
+
+DESCRIPTION="A program to analyze and adjust MP3 files to same volume"
+HOMEPAGE="http://mp3gain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ app-arch/unzip
+ media-sound/mpg123
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-CVE-2017-12911.patch )
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin mp3gain
+}