summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-06-13 23:38:28 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-22 06:19:34 +0000
commit612bbda85991927cd57f5d0f946338768aa54af4 (patch)
tree3e80fdc78b140383b207d0b0d4fb14d2bbb25b35 /media-sound/mpd/mpd-0.19.15.ebuild
parentmedia-sound/mpd: Version bump to 0.9.15 (diff)
downloadgentoo-612bbda85991927cd57f5d0f946338768aa54af4.tar.gz
gentoo-612bbda85991927cd57f5d0f946338768aa54af4.tar.bz2
gentoo-612bbda85991927cd57f5d0f946338768aa54af4.zip
media-sound/mpd: Fix configure with >=sys-apps/systemd-230
Gentoo-bug: 584742 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1651 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-sound/mpd/mpd-0.19.15.ebuild')
-rw-r--r--media-sound/mpd/mpd-0.19.15.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-sound/mpd/mpd-0.19.15.ebuild b/media-sound/mpd/mpd-0.19.15.ebuild
index 386d24ada927..ed101036896e 100644
--- a/media-sound/mpd/mpd-0.19.15.ebuild
+++ b/media-sound/mpd/mpd-0.19.15.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit eutils flag-o-matic linux-info multilib systemd user
+inherit autotools eutils flag-o-matic linux-info multilib systemd user
DESCRIPTION="The Music Player Daemon (mpd)"
HOMEPAGE="http://www.musicpd.org"
@@ -102,7 +102,10 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-mpd )
"
-PATCHES=( "${FILESDIR}"/${PN}-0.18.conf.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.18.conf.patch
+ "${FILESDIR}"/${PN}-0.9.15-systemd.patch # bug 584742
+)
pkg_setup() {
use network || ewarn "Icecast and Shoutcast streaming needs networking."
@@ -133,6 +136,7 @@ pkg_setup() {
src_prepare() {
cp -f doc/mpdconf.example doc/mpdconf.dist || die "cp failed"
default
+ eautoreconf
}
src_configure() {
@@ -205,7 +209,7 @@ src_configure() {
$(use_enable sid sidplay) \
$(use_enable sndfile sndfile) \
$(use_enable sqlite) \
- $(use_enable systemd systemd-daemon) \
+ $(use_enable systemd) \
$(use_enable vorbis) \
$(use_enable wavpack) \
$(use_enable wildmidi) \