summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-11-09 04:36:17 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-11-21 01:34:56 +0100
commit1e32cf3f3cab7f2ff274fc2baaa61f7368152756 (patch)
treeb1c04ca1d234716e6fefd1e7026d566e72b76350 /media-sound/mpdscribble/mpdscribble-0.22.ebuild
parentdev-util/catalyst: update HOMEPAGE. (diff)
downloadgentoo-1e32cf3f3cab7f2ff274fc2baaa61f7368152756.tar.gz
gentoo-1e32cf3f3cab7f2ff274fc2baaa61f7368152756.tar.bz2
gentoo-1e32cf3f3cab7f2ff274fc2baaa61f7368152756.zip
media-sound/mpdscribble: add 9999 version.
Closes: https://github.com/gentoo/gentoo/pull/2786
Diffstat (limited to 'media-sound/mpdscribble/mpdscribble-0.22.ebuild')
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.22.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/media-sound/mpdscribble/mpdscribble-0.22.ebuild b/media-sound/mpdscribble/mpdscribble-0.22.ebuild
index e498ca6e2e7f..d995367e13f6 100644
--- a/media-sound/mpdscribble/mpdscribble-0.22.ebuild
+++ b/media-sound/mpdscribble/mpdscribble-0.22.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils
DESCRIPTION="An MPD client that submits information to Audioscrobbler"
@@ -14,19 +14,16 @@ SLOT="0"
KEYWORDS="amd64 ~hppa ~ppc x86"
IUSE="+curl"
-RDEPEND=">=dev-libs/glib-2.16:2
- >=media-libs/libmpdclient-2.2
+RDEPEND="dev-libs/glib
+ media-libs/libmpdclient
curl? ( net-misc/curl )
!curl? ( net-libs/libsoup:2.4 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
- local myclient=soup
- use curl && myclient=curl
econf \
- --with-http-client=${myclient} \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --with-http-client=$(usex curl curl soup)
}
src_install() {