summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-01-20 11:29:06 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-20 11:29:06 +0100
commit7653a1bfb08c8171d41633e38fcf532968171c56 (patch)
tree9837bcc199918393fa25976522de9905afa66689 /media-sound/mpg123
parentdev-java/xerial-core: EAPI 8, min java 1.8:* (diff)
downloadgentoo-7653a1bfb08c8171d41633e38fcf532968171c56.tar.gz
gentoo-7653a1bfb08c8171d41633e38fcf532968171c56.tar.bz2
gentoo-7653a1bfb08c8171d41633e38fcf532968171c56.zip
media-sound/mpg123: removed obsolete 1.29.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.29.2.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index cc2e9aa8c98f..5e4d7b578dfa 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1 @@
-DIST mpg123-1.29.2.tar.bz2 1069976 BLAKE2B 2580f1a4ce3a9ba7016c61289da08e0185eed363d51e4477bab34f1e4ac296b9ab4912a565afcffd29c16f5287c320d8a3d4f92872a0b8a7e2a32c147d87b7c9 SHA512 ffb82ffbebedeb12783338b5159bf055afd25cb77e1b705bef29f04fa50bcb2ceaf2a6418d0e111fab1151ea956fe48ba3576d978e6b0c8f4ca72c3883608ec0
DIST mpg123-1.29.3.tar.bz2 1069979 BLAKE2B d01a8d77ffb6c344592d1b90026ee25ae12eb2e063446e88370e0aa508705a843b987f1a400351b5ed87d211251057b7b31a2e653401b800fe9871ac2a5756fc SHA512 0d8db63f9bae1507887bc5241a56abccfeb767b7ba8362eb0fce9de2f63369e57fdd6f25a953f8ef5f9ead4f400237db51914816e278566fdf8e6f205ebca5d6
diff --git a/media-sound/mpg123/mpg123-1.29.2.ebuild b/media-sound/mpg123/mpg123-1.29.2.ebuild
deleted file mode 100644
index b49ebad52d41..000000000000
--- a/media-sound/mpg123/mpg123-1.29.2.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-# Note: build system prefers libsdl2 > libsdl. We could in theory add both
-# but it's tricky when it comes to handling switching between them properly.
-# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
-RDEPEND="
- dev-libs/libltdl:0
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
- nas? ( media-libs/nas )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl2 )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-IDEPEND="app-eselect/eselect-mpg123"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-src_prepare() {
- default
- elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
- local _audio=dummy
- local _output=dummy
- local _cpu=generic_fpu
-
- # Build fails without -D_GNU_SOURCE like this:
- # error: ‘struct hostent’ has no member named ‘h_addr’
- append-cflags -D_GNU_SOURCE
-
- if $(multilib_is_native_abi) ; then
- local flag
- for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
- if use ${flag}; then
- _audio+=" ${flag/pulseaudio/pulse}"
- _output=${flag/pulseaudio/pulse}
- fi
- done
- fi
-
- use cpu_flags_ppc_altivec && _cpu=altivec
-
- if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
- use cpu_flags_x86_sse && _cpu=x86-64
- elif use x86 && gcc-specs-pie ; then
- # Don't use any mmx, 3dnow, sse and 3dnowext
- # bug #164504
- _cpu=generic_fpu
- else
- use cpu_flags_x86_mmx && _cpu=mmx
- use cpu_flags_x86_3dnow && _cpu=3dnow
- use cpu_flags_x86_sse && _cpu=x86
- use cpu_flags_x86_3dnowext && _cpu=x86
- fi
-
- local myconf=(
- --with-optimization=0
- --with-audio="${_audio}"
- --with-default-audio=${_output}
- --with-cpu=${_cpu}
- --enable-network
- $(use_enable ipv6)
- --enable-int-quality=$(usex int-quality)
- )
-
- multilib_is_native_abi || myconf+=( --disable-modules )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- if ! $(multilib_is_native_abi) ; then
- sed -i -e 's:src doc:src/libmpg123:' Makefile || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- mv "${ED}"/usr/bin/mpg123{,-mpg123}
- find "${ED}" -type f -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
- eselect mpg123 update ifunset
-}