summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-08 15:41:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-08 15:46:04 +0200
commitd2a988fef9469ceb4f412d9b9fdd4ef8507ad289 (patch)
tree5700079a192d6db4d0a9676ca0f7d7c417b3a188 /media-sound/mumble
parentmedia-gfx/imagemagick: drop old (diff)
downloadgentoo-d2a988fef9469ceb4f412d9b9fdd4ef8507ad289.tar.gz
gentoo-d2a988fef9469ceb4f412d9b9fdd4ef8507ad289.tar.bz2
gentoo-d2a988fef9469ceb4f412d9b9fdd4ef8507ad289.zip
media-sound/mumble: Bump to version 1.3.0
Closes: https://bugs.gentoo.org/693788 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/mumble')
-rw-r--r--media-sound/mumble/Manifest1
-rw-r--r--media-sound/mumble/mumble-1.3.0.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/media-sound/mumble/Manifest b/media-sound/mumble/Manifest
index 7b1545ca0088..38d83a9bc7d9 100644
--- a/media-sound/mumble/Manifest
+++ b/media-sound/mumble/Manifest
@@ -1,2 +1,3 @@
DIST mumble-1.3.0-rc1.tar.gz 8638701 BLAKE2B 6c97c528e8b598bb86a7318e997067706216436b37aabb06931e509d1c713d0104aa599a72235dd0afd46b34779205bd622a496bf14fd54aa065d9ab1d869725 SHA512 e993b18b0ecf620d3a9a89f145c18b9ecde3aaf9b7217e235b7472908c81a365323c8683dd6fc9ed14b108160f8bf5244369c2a9ee57c22595550220d158516c
DIST mumble-1.3.0-rc2.tar.gz 8759830 BLAKE2B 4df1001a174d042221a674a21dcdb7165742cba2428f778eb6ef7fcfe8128734f4207230222971fa97622af3ea81e40b676cc089e45704be3fecf76f97f72a36 SHA512 b31a92cbe9d2d973cb06e5f3bb237de22f0fa5f242e6a8141ffaa735268ca41097bda44445a73ea5dafef6ef3ff7a5050c52c7f9b9f5600d400e57aff6f2e4c4
+DIST mumble-1.3.0.tar.gz 8788587 BLAKE2B cb870b043506eaa0fb15a21c95c125eb49082dde55b9c1a49e3ffff318477b27b45d75d18d3db83e247446efaddb2253ff520ec19da04b465a7e9a33b22064d1 SHA512 2a629fc97f3c7c587c9a3b40fc96cf15d668acada37282ec1c4a5b169ad37717d60af94d12c7bce45f2816c265f76a99ebad40a006adcf8ca38a117e7c0a4122
diff --git a/media-sound/mumble/mumble-1.3.0.ebuild b/media-sound/mumble/mumble-1.3.0.ebuild
new file mode 100644
index 000000000000..ca1f49e6d6bd
--- /dev/null
+++ b/media-sound/mumble/mumble-1.3.0.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop multilib-build qmake-utils xdg
+
+DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
+HOMEPAGE="https://wiki.mumble.info"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
+ EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src )
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ else
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
+ https://dl.mumble.info/${MY_P}.tar.gz"
+ S="${WORKDIR}/${P/_*}"
+ fi
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+alsa +dbus debug g15 jack libressl +opus oss pch portaudio pulseaudio +rnnoise speech zeroconf"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=dev-libs/protobuf-2.2.0:=
+ >=media-libs/libsndfile-1.0.20[-minimal]
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ sys-apps/lsb-release
+ x11-libs/libX11
+ x11-libs/libXi
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ g15? ( app-misc/g15daemon )
+ jack? ( virtual/jack )
+ !libressl? ( >=dev-libs/openssl-1.0.0b:0= )
+ libressl? ( dev-libs/libressl )
+ opus? ( >=media-libs/opus-1.0.1 )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.41.0
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+# NB: qmake does not support multilib but it's fine to configure
+# for the native ABI here
+src_configure() {
+ myuse() {
+ [[ -n "${1}" ]] || die "myuse: No use option given"
+ use ${1} || echo no-${1}
+ }
+
+ local conf_add=(
+ bundled-celt
+ no-bundled-opus
+ no-bundled-speex
+ no-embed-qt-translations
+ no-server
+ no-update
+ $(myuse alsa)
+ $(myuse dbus)
+ $(usex debug 'symbols debug' release)
+ $(myuse g15)
+ $(usex jack '' no-jackaudio)
+ $(myuse opus)
+ $(myuse oss)
+ $(myuse portaudio)
+ $(myuse pulseaudio)
+ $(myuse rnnoise)
+ $(usex speech '' no-speechd)
+ $(usex zeroconf '' no-bonjour)
+ )
+
+ use pch || conf_add+=( no-pch )
+
+ eqmake5 "${S}/main.pro" -recursive \
+ CONFIG+="${conf_add[*]}" \
+ DEFINES+="PLUGIN_PATH=/usr/$(get_libdir)/mumble"
+}
+
+multilib_src_compile() {
+ local emake_args=(
+ # place libmumble* in a subdirectory
+ DESTDIR_ADD="/${MULTILIB_ABI_FLAG}"
+ {C,L}FLAGS_ADD="$(get_abi_CFLAGS)"
+ )
+ # build only overlay library for other ABIs
+ multilib_is_native_abi || emake_args+=( -C overlay_gl )
+ emake "${emake_args[@]}"
+ emake clean
+}
+
+src_compile() {
+ multilib_foreach_abi multilib_src_compile
+}
+
+multilib_src_install() {
+ local dir=$(usex debug debug release)
+ dolib.so "${dir}/${MULTILIB_ABI_FLAG}"/libmumble.so*
+ if multilib_is_native_abi; then
+ dobin "${dir}"/mumble
+ dolib.so "${dir}"/libcelt0.so* "${dir}"/plugins/lib*.so*
+ fi
+}
+
+src_install() {
+ multilib_foreach_abi multilib_src_install
+
+ newdoc README.Linux README
+ dodoc CHANGES
+ dobin scripts/mumble-overlay
+
+ insinto /usr/share/services
+ doins scripts/mumble.protocol
+
+ domenu scripts/mumble.desktop
+
+ doicon -s scalable icons/mumble.svg
+
+ doman man/mumble-overlay.1
+ doman man/mumble.1
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ echo
+ elog "Visit http://mumble.sourceforge.net/ for futher configuration instructions."
+ elog "Run mumble-overlay to start the OpenGL overlay (after starting mumble)."
+ echo
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}