summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/musescore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/musescore')
-rw-r--r--media-sound/musescore/Manifest3
-rw-r--r--media-sound/musescore/files/musescore-1.1-sline.patch11
-rw-r--r--media-sound/musescore/files/musescore-1.2-cflags.patch64
-rw-r--r--media-sound/musescore/files/musescore-1.3-cflags.patch113
-rw-r--r--media-sound/musescore/files/musescore-1.3-freetype251.patch19
-rw-r--r--media-sound/musescore/metadata.xml8
-rw-r--r--media-sound/musescore/musescore-1.1.ebuild60
-rw-r--r--media-sound/musescore/musescore-1.2.ebuild59
-rw-r--r--media-sound/musescore/musescore-1.3.ebuild60
9 files changed, 397 insertions, 0 deletions
diff --git a/media-sound/musescore/Manifest b/media-sound/musescore/Manifest
new file mode 100644
index 000000000000..9b9c542c1b96
--- /dev/null
+++ b/media-sound/musescore/Manifest
@@ -0,0 +1,3 @@
+DIST mscore-1.1.tar.bz2 82410619 SHA256 d160b4dabbee5bbe7c0ba6e653e90fd36fae07ab7fffed2c6991b65123fee10c
+DIST mscore-1.2.tar.bz2 85739954 SHA256 e7f6c6cd705381a4583db267acbfed2dc9ce3985b20ed5407cd9cfe208d74d81 SHA512 aa92520b34d597db9fcf3c0121a56ceb7bfd8008ec5520cb318129da1c127426b0b789aab9d4754526d22c00307cc730d3c1b5a23e4252d5c5ca9e2b6cd95a38 WHIRLPOOL 6abcd260e908a045b43d210d274911cb87acacc1707638bc625aae817ad3791b13b079b6eaf44fb8b600031e7492eae86d88a6d6cb923c6badcdfe1b89314734
+DIST mscore-1.3.tar.bz2 94704857 SHA256 a0b60cc892ac0266c58fc6392be72c0a21c3aa7fd0b6e4f1dddad1c8b36be683 SHA512 65369cc62f401c059c3452ada8a8861b6dd36df54313f4039f1a8a96771a37926bb40240df88d150b99cee7bc8a4ee8963a4fdb5a162defc8be660810cbc49b4 WHIRLPOOL 89a91da5607ce8163b74f6a787b57f15ef615a32ede154f943a3d87e78f348b145d14e89c487797df1bff577085b36d5e21c6ffb2daf044cf48b01f350538be1
diff --git a/media-sound/musescore/files/musescore-1.1-sline.patch b/media-sound/musescore/files/musescore-1.1-sline.patch
new file mode 100644
index 000000000000..15345803b63f
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.1-sline.patch
@@ -0,0 +1,11 @@
+--- mscore-1.1/mscore/mscore/exportxml.cpp.orig
++++ mscore-1.1/mscore/mscore/exportxml.cpp
+@@ -2363,7 +2363,7 @@
+ el->userOff().y());
+ */
+ if (el->type() == HAIRPIN || el->type() == OTTAVA || el->type() == TEXTLINE) {
+- SLine* sl = static_cast<const SLine*>(el);
++ SLine* sl = static_cast<SLine*>(el);
+ // printf("slin segsz=%d", sl->lineSegments().size());
+ if (sl->lineSegments().size() > 0) {
+ LineSegment* seg = sl->lineSegments().at(0);
diff --git a/media-sound/musescore/files/musescore-1.2-cflags.patch b/media-sound/musescore/files/musescore-1.2-cflags.patch
new file mode 100644
index 000000000000..d3450b8cae92
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.2-cflags.patch
@@ -0,0 +1,64 @@
+--- mscore-1.2/mscore/al/CMakeLists.txt
++++ mscore-1.2/mscore/al/CMakeLists.txt
+@@ -42,7 +42,7 @@
+
+ set_source_files_properties(
+ dsp.cpp xml.cpp tempo.cpp sig.cpp pos.cpp fraction.cpp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ set_source_files_properties(dspSSE.cpp
+--- mscore-1.2/mscore/awl/CMakeLists.txt
++++ mscore-1.2/mscore/awl/CMakeLists.txt
+@@ -61,7 +61,7 @@
+
+ set_target_properties( awl
+ PROPERTIES COMPILE_FLAGS
+- "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(awl mops1)
+--- mscore-1.2/mscore/CMakeLists.txt
++++ mscore-1.2/mscore/CMakeLists.txt
+@@ -253,9 +253,6 @@
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+
+-set(CMAKE_CXX_FLAGS_DEBUG "")
+-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
+-
+ if (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+ set(FLAGS -DQT_DEBUG -DQT_DLL)
+@@ -264,9 +261,9 @@
+ endif (MINGW)
+ else (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
+ else (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_NO_DEBUG)
+ endif (MINGW)
+ endif (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+
+@@ -276,7 +273,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.pch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS}
++ -x c++-header ${FLAGS}
+ -I${QT_INCLUDE_DIR}
+ -o all.h.pch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
+@@ -287,7 +284,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.gch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS} -m32
++ -x c++-header ${FLAGS}
+ -I${QT_HEADERS_DIR}
+ -o all.h.gch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
diff --git a/media-sound/musescore/files/musescore-1.3-cflags.patch b/media-sound/musescore/files/musescore-1.3-cflags.patch
new file mode 100644
index 000000000000..44af8851be97
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.3-cflags.patch
@@ -0,0 +1,113 @@
+--- mscore-1.3/mscore/al/CMakeLists.txt
++++ mscore-1.3/mscore/al/CMakeLists.txt
+@@ -42,7 +42,7 @@
+
+ set_source_files_properties(
+ dsp.cpp xml.cpp tempo.cpp sig.cpp pos.cpp fraction.cpp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ set_source_files_properties(dspSSE.cpp
+--- mscore-1.3/mscore/awl/CMakeLists.txt
++++ mscore-1.3/mscore/awl/CMakeLists.txt
+@@ -61,7 +61,7 @@
+
+ set_target_properties( awl
+ PROPERTIES COMPILE_FLAGS
+- "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(awl mops1)
+--- mscore-1.3/mscore/CMakeLists.txt
++++ mscore-1.3/mscore/CMakeLists.txt
+@@ -257,9 +257,6 @@
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+
+-set(CMAKE_CXX_FLAGS_DEBUG "-g")
+-set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
+-
+ if (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+ set(FLAGS -DQT_DEBUG -DQT_DLL)
+@@ -272,9 +269,9 @@
+ endif (MINGW)
+ else (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+ if (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_DLL -DQT_NO_DEBUG)
+ else (MINGW)
+- set(FLAGS -O2 -DNDEBUG -DQT_NO_DEBUG)
++ set(FLAGS -DNDEBUG -DQT_NO_DEBUG)
+ endif (MINGW)
+ endif (CMAKE_BUILD_TYPE STREQUAL "DEBUG")
+
+@@ -284,7 +281,7 @@
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/all.h.gch
+ COMMAND ${CMAKE_CXX_COMPILER}
+- -x c++-header -g ${FLAGS}
++ -x c++-header ${FLAGS}
+ -I${QT_HEADERS_DIR}
+ -o all.h.gch all.h
+ DEPENDS ${PROJECT_BINARY_DIR}/all.h
+--- mscore-1.3/mscore/fluid/CMakeLists.txt
++++ mscore-1.3/mscore/fluid/CMakeLists.txt
+@@ -28,7 +28,7 @@
+ )
+
+ set_target_properties( fluid
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(fluid mops1)
+--- mscore-1.3/mscore/mscore/CMakeLists.txt
++++ mscore-1.3/mscore/mscore/CMakeLists.txt
+@@ -199,7 +199,7 @@
+ if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+ set_target_properties( mscore
+ PROPERTIES
+- COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
++ COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQT_SCRIPT_LIB"
+ LINK_FLAGS "${PROJECT_BINARY_DIR}/resfile.o -mwindows -mconsole -L ${CROSSQT}/lib"
+ )
+ else(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+--- mscore-1.3/mscore/ofqf/CMakeLists.txt
++++ mscore-1.3/mscore/ofqf/CMakeLists.txt
+@@ -34,8 +34,8 @@
+ )
+
+ set_target_properties( ofqf
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(ofqf mops1)
+-ADD_DEPENDENCIES(ofqf mops2)
+\ No newline at end of file
++ADD_DEPENDENCIES(ofqf mops2)
+--- mscore-1.3/mscore/osdabzip/CMakeLists.txt
++++ mscore-1.3/mscore/osdabzip/CMakeLists.txt
+@@ -29,7 +29,7 @@
+ )
+
+ set_target_properties( osdabzip
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(osdabzip mops1)
+--- mscore-1.3/mscore/singleapp/src/CMakeLists.txt
++++ mscore-1.3/mscore/singleapp/src/CMakeLists.txt
+@@ -35,7 +35,7 @@
+ )
+
+ set_target_properties( qtsingleapp
+- PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ PROPERTIES COMPILE_FLAGS "-include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ ADD_DEPENDENCIES(qtsingleapp mops1)
diff --git a/media-sound/musescore/files/musescore-1.3-freetype251.patch b/media-sound/musescore/files/musescore-1.3-freetype251.patch
new file mode 100644
index 000000000000..0fbad400e8f9
--- /dev/null
+++ b/media-sound/musescore/files/musescore-1.3-freetype251.patch
@@ -0,0 +1,19 @@
+Date: Tue, 15 Apr 2014 16:36:51 +0200
+Subject: [PATCH] Fix compilation with >=freetype-2.5.1 while remaining
+ compatible with older freetype versions.
+
+This fixes Gentoo bug #507712 (https://bugs.gentoo.org/507712)
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- mscore-1.3/mscore/mscore/genft.cpp
++++ mscore-1.3/mscore/mscore/genft.cpp
+@@ -27,7 +27,7 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include <freetype/tttables.h>
++#include FT_TRUETYPE_TABLES_H
+ #include "al/xml.h"
+
+ QMap<int, int> codemap;
diff --git a/media-sound/musescore/metadata.xml b/media-sound/musescore/metadata.xml
new file mode 100644
index 000000000000..2db48a7c9199
--- /dev/null
+++ b/media-sound/musescore/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">mscore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/musescore/musescore-1.1.ebuild b/media-sound/musescore/musescore-1.1.ebuild
new file mode 100644
index 000000000000..627b4afadcb5
--- /dev/null
+++ b/media-sound/musescore/musescore-1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils eutils font
+
+MY_P="mscore-${PV}"
+
+DESCRIPTION="WYSIWYG Music Score Typesetter"
+HOMEPAGE="http://mscore.sourceforge.net"
+SRC_URI="mirror://sourceforge/mscore/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ >=media-libs/libsndfile-1.0.19
+ media-libs/portaudio
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ dev-qt/qtscript:4
+ dev-qt/qtsvg:4
+ x11-libs/qtscriptgenerator"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-context
+ app-doc/doxygen
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/mscore"
+VARTEXFONTS="${T}/fonts"
+FONT_SUFFIX="ttf"
+FONT_S="${S}/mscore/fonts"
+
+src_prepare() {
+ # Fix invalid conversion error
+ epatch "${FILESDIR}"/${P}-sline.patch
+
+ # Don't build redundant qtscriptgenerator libs
+ sed -i -e '/^set(BUILD_SCRIPTGEN/s/TRUE/FALSE/' CMakeLists.txt || die
+}
+
+src_compile() {
+ cmake-utils_src_make lupdate
+ cmake-utils_src_make lrelease
+ cmake-utils_src_make
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+ dodoc ChangeLog NEWS README
+ doman packaging/mscore.1
+}
diff --git a/media-sound/musescore/musescore-1.2.ebuild b/media-sound/musescore/musescore-1.2.ebuild
new file mode 100644
index 000000000000..75acf326d3e0
--- /dev/null
+++ b/media-sound/musescore/musescore-1.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils eutils font
+
+MY_P="mscore-${PV}"
+
+DESCRIPTION="WYSIWYG Music Score Typesetter"
+HOMEPAGE="http://mscore.sourceforge.net"
+SRC_URI="mirror://sourceforge/mscore/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ >=media-libs/libsndfile-1.0.19
+ media-libs/portaudio
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ dev-qt/qtscript:4
+ dev-qt/qtsvg:4
+ x11-libs/qtscriptgenerator"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-context
+ app-doc/doxygen
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/mscore"
+VARTEXFONTS="${T}/fonts"
+FONT_SUFFIX="ttf"
+FONT_S="${S}/mscore/fonts"
+
+src_prepare() {
+ # Don't build redundant qtscriptgenerator libs
+ sed -i -e '/^set(BUILD_SCRIPTGEN/s/TRUE/FALSE/' CMakeLists.txt || die
+
+ epatch "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_compile() {
+ cmake-utils_src_make lupdate
+ cmake-utils_src_make lrelease
+ cmake-utils_src_make
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+ dodoc ChangeLog NEWS README
+ doman packaging/mscore.1
+}
diff --git a/media-sound/musescore/musescore-1.3.ebuild b/media-sound/musescore/musescore-1.3.ebuild
new file mode 100644
index 000000000000..fc1ae3480726
--- /dev/null
+++ b/media-sound/musescore/musescore-1.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils font
+
+MY_P="mscore-${PV}"
+
+DESCRIPTION="WYSIWYG Music Score Typesetter"
+HOMEPAGE="http://mscore.sourceforge.net"
+SRC_URI="mirror://sourceforge/mscore/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ >=media-libs/libsndfile-1.0.19
+ media-libs/portaudio
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ sys-libs/zlib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4
+ dev-qt/qtscript:4
+ dev-qt/qtsvg:4
+ x11-libs/qtscriptgenerator"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-context
+ app-doc/doxygen
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/mscore"
+VARTEXFONTS="${T}/fonts"
+FONT_SUFFIX="ttf"
+FONT_S="${S}/mscore/fonts"
+
+src_prepare() {
+ # don't build redundant qtscriptgenerator libs
+ sed -i '/^set(BUILD_SCRIPTGEN/s/TRUE/FALSE/' CMakeLists.txt || die
+
+ epatch "${FILESDIR}"/${P}-cflags.patch \
+ "${FILESDIR}"/${P}-freetype251.patch
+}
+
+src_compile() {
+ cmake-utils_src_make lupdate
+ cmake-utils_src_make lrelease
+ cmake-utils_src_make
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+ dodoc ChangeLog NEWS README
+ doman packaging/mscore.1
+}