summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-18 13:41:13 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-18 13:41:13 +0200
commit92625300f3c6f487a6d3a4ad89794a326e8235d8 (patch)
treec2fffe7dd2e7330e9b936fb0245707ef91814fee /media-sound/oggtst/oggtst-0.0.ebuild
parentgames-puzzle/triptych: [QA] Version the distfile (diff)
downloadgentoo-92625300f3c6f487a6d3a4ad89794a326e8235d8.tar.gz
gentoo-92625300f3c6f487a6d3a4ad89794a326e8235d8.tar.bz2
gentoo-92625300f3c6f487a6d3a4ad89794a326e8235d8.zip
media-sound/oggtst: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/oggtst/oggtst-0.0.ebuild')
-rw-r--r--media-sound/oggtst/oggtst-0.0.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/media-sound/oggtst/oggtst-0.0.ebuild b/media-sound/oggtst/oggtst-0.0.ebuild
index 0a24362b9b13..52a8223e6f76 100644
--- a/media-sound/oggtst/oggtst-0.0.ebuild
+++ b/media-sound/oggtst/oggtst-0.0.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit autotools
DESCRIPTION="A tool for calculating ogg-vorbis playing time"
HOMEPAGE="http://gnometoaster.rulez.org/"
-SRC_URI="http://gnometoaster.rulez.org/archive/${PN}.tgz"
+SRC_URI="mirror://gentoo/${PN}.tgz -> ${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE=""
-RDEPEND=">=media-libs/libao-0.8.0
- >=media-libs/libvorbis-1.0_rc2"
+RDEPEND="
+ media-libs/libao:=
+ media-libs/libvorbis:="
+DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # upstream didn't use make dist to create the tarball, there are
- # unbound symlinks inside it.
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ # upstream didn't use make dist to create the tarball,
+ # there are unbound symlinks inside it.
eautoreconf
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README
-}