summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/orpheus/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/orpheus/files')
-rw-r--r--media-sound/orpheus/files/1.5-amd64.patch31
-rw-r--r--media-sound/orpheus/files/101_fix-buffer-overflow.diff15
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-bufsize.patch13
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-constify.patch60
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-cppflags.patch12
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-gcc47.patch15
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-nolibghttp.patch15
7 files changed, 161 insertions, 0 deletions
diff --git a/media-sound/orpheus/files/1.5-amd64.patch b/media-sound/orpheus/files/1.5-amd64.patch
new file mode 100644
index 000000000000..eac0ab0a2c61
--- /dev/null
+++ b/media-sound/orpheus/files/1.5-amd64.patch
@@ -0,0 +1,31 @@
+--- orpheus-1.5/kkstrtext-0.1/kkstrtext.cc 2004-01-15 21:25:31.000000000 +0100
++++ orpheus-1.5-new/kkstrtext-0.1/kkstrtext.cc 2006-08-28 11:48:36.926598598 +0200
+@@ -431,7 +431,7 @@
+ }
+
+ int intcompare(void *s1, void *s2) {
+- return (int) s1 != (int) s2;
++ return (long) s1 != (long) s2;
+ }
+
+ string i2str(int i) {
+@@ -885,7 +885,7 @@
+ #ifdef HAVE_ICONV
+ iconv_t cd = iconv_open(tocs.c_str(), fromcs.c_str());
+
+- if(((int) cd) != -1) {
++ if(((long) cd) != -1) {
+ string r, text(atext);
+ size_t inleft, outleft, soutleft;
+ char *inbuf, *outbuf, *sinbuf, *soutbuf;
+--- orpheus-1.5/kkconsui-0.1/src/texteditor.cc 2003-09-09 23:51:33.000000000 +0200
++++ orpheus-1.5-new/kkconsui-0.1/src/texteditor.cc 2006-08-28 11:56:10.082753610 +0200
+@@ -1940,7 +1940,7 @@
+ }
+
+ int texteditor::findint(void *p1, void *p2) {
+- return *(int *) p1 != (int) p2;
++ return *(long *) p1 != (long) p2;
+ }
+
+ int texteditor::findhighline(void *p1, void *p2) {
diff --git a/media-sound/orpheus/files/101_fix-buffer-overflow.diff b/media-sound/orpheus/files/101_fix-buffer-overflow.diff
new file mode 100644
index 000000000000..4d6c8e4e18a4
--- /dev/null
+++ b/media-sound/orpheus/files/101_fix-buffer-overflow.diff
@@ -0,0 +1,15 @@
+Fix a stack-based buffer overflow in kkstrtext.h in ktools library.
+(CVE-2005-3863) (Closes: #368402)
+Index: orpheus-1.5/kkstrtext-0.1/kkstrtext.h
+===================================================================
+--- orpheus-1.5.orig/kkstrtext-0.1/kkstrtext.h 2003-12-14 11:51:38.000000000 +0100
++++ orpheus-1.5/kkstrtext-0.1/kkstrtext.h 2006-08-01 21:57:14.000000000 +0200
+@@ -87,7 +87,7 @@
+ { \
+ va_list vgs__ap; char vgs__buf[1024]; \
+ va_start(vgs__ap, fmt); \
+- vsprintf(vgs__buf, fmt, vgs__ap); c = vgs__buf; \
++ vsnprintf(vgs__buf, 1024, fmt, vgs__ap); c = vgs__buf; \
+ va_end(vgs__ap); \
+ }
+
diff --git a/media-sound/orpheus/files/orpheus-1.6-bufsize.patch b/media-sound/orpheus/files/orpheus-1.6-bufsize.patch
new file mode 100644
index 000000000000..319fcd83eecc
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-bufsize.patch
@@ -0,0 +1,13 @@
+Index: orpheus-1.6/kkstrtext-0.1/kkstrtext.cc
+===================================================================
+--- orpheus-1.6.orig/kkstrtext-0.1/kkstrtext.cc
++++ orpheus-1.6/kkstrtext-0.1/kkstrtext.cc
+@@ -1132,7 +1132,7 @@ string striprtf(const string &s, const s
+ bunicode = false;
+ if(unichar.substr(0, 4).find_first_not_of("0123456789") == -1) {
+ long l = strtol(unichar.substr(0, 4).c_str(), 0, 0);
+- char ubuf[sizeof(long)+4];
++ char ubuf[sizeof(long)*2+4];
+ #ifdef HAVE_ICONV
+ memcpy(ubuf, "\xff\xfe", 2);
+ memcpy(ubuf+2, &l, sizeof(long));
diff --git a/media-sound/orpheus/files/orpheus-1.6-constify.patch b/media-sound/orpheus/files/orpheus-1.6-constify.patch
new file mode 100644
index 000000000000..8255b4094ef6
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-constify.patch
@@ -0,0 +1,60 @@
+Index: orpheus-1.6/kkstrtext-0.1/kkstrtext.cc
+===================================================================
+--- orpheus-1.6.orig/kkstrtext-0.1/kkstrtext.cc
++++ orpheus-1.6/kkstrtext-0.1/kkstrtext.cc
+@@ -41,17 +41,17 @@ char *strimlead(char *str) { return tri
+ char *strimtrail(char *str) { return trimtrail(str, " \t"); }
+ char *strim(char *str) { return trim(str, " \t"); }
+
+-char *trimlead(char *str, char *chr) {
++char *trimlead(char *str, const char *chr) {
+ while(strchr(chr, str[0]) && strlen(str)) strcpy(str, str + 1);
+ return str;
+ }
+
+-char *trimtrail(char *str, char *chr) {
++char *trimtrail(char *str, const char *chr) {
+ while(strchr(chr, str[strlen(str)-1]) && strlen(str)) str[strlen(str)-1] = 0;
+ return str;
+ }
+
+-char *trim(char *str, char *chr) {
++char *trim(char *str, const char *chr) {
+ return trimlead(trimtrail(str, chr), chr);
+ }
+
+@@ -370,7 +370,7 @@ const char *strqstr(const char *s, const
+ return ret;
+ }
+
+-char *strinsert(char *buf, int pos, char *ins) {
++char *strinsert(char *buf, int pos, const char *ins) {
+ char *p = strdup(buf+pos);
+ memcpy(buf+pos+strlen(ins), p, strlen(p)+1);
+ memcpy(buf+pos, ins, strlen(ins));
+Index: orpheus-1.6/kkstrtext-0.1/kkstrtext.h
+===================================================================
+--- orpheus-1.6.orig/kkstrtext-0.1/kkstrtext.h
++++ orpheus-1.6/kkstrtext-0.1/kkstrtext.h
+@@ -119,9 +119,9 @@ __KTOOL_BEGIN_C
+
+ char *strcut(char *strin, int frompos, int count);
+
+-char *trimlead(char *str, char *chr);
+-char *trimtrail(char *str, char *chr);
+-char *trim(char *str, char *chr);
++char *trimlead(char *str, const char *chr);
++char *trimtrail(char *str, const char *chr);
++char *trim(char *str, const char *chr);
+
+ char *strimlead(char *str);
+ char *strimtrail(char *str);
+@@ -145,7 +145,7 @@ const char *strqstr(const char *s,
+ const char *esc = "");
+
+ char *strccat(char *dest, char c);
+-char *strinsert(char *buf, int pos, char *ins);
++char *strinsert(char *buf, int pos, const char *ins);
+ char *strcinsert(char *buf, int pos, char ins);
+
+ int strchcount(char *s, char *accept);
diff --git a/media-sound/orpheus/files/orpheus-1.6-cppflags.patch b/media-sound/orpheus/files/orpheus-1.6-cppflags.patch
new file mode 100644
index 000000000000..bf7effbcd9d9
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-cppflags.patch
@@ -0,0 +1,12 @@
+Index: orpheus-1.6/kkconsui-0.1/src/Makefile.am
+===================================================================
+--- orpheus-1.6.orig/kkconsui-0.1/src/Makefile.am
++++ orpheus-1.6/kkconsui-0.1/src/Makefile.am
+@@ -1,6 +1,6 @@
+ INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/../kkstrtext -I$(top_srcdir)/../kkstrtext-0.1
+ noinst_LIBRARIES = libsrc.a
+-CPPFLAGS =
++AM_CPPFLAGS =
+ libsrc_a_SOURCES = treeview.cc colorschemer.cc textinputline.cc fileselector.cc textwindow.cc texteditor.cc dialogbox.cc screenarea.cc textbrowser.cc abstractui.cc horizontalbar.cc linkedlist.cc cmenus.cc conscommon.cc
+ EXTRA_DIST = treeview.cc colorschemer.cc textinputline.cc fileselector.cc textwindow.cc texteditor.cc dialogbox.cc screenarea.cc textbrowser.cc abstractui.cc horizontalbar.cc linkedlist.cc cmenus.cc conscommon.cc
+ SUBDIRS =
diff --git a/media-sound/orpheus/files/orpheus-1.6-gcc47.patch b/media-sound/orpheus/files/orpheus-1.6-gcc47.patch
new file mode 100644
index 000000000000..605bb9927760
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/430386
+
+ src/streamtrack.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/streamtrack.cc
++++ b/src/streamtrack.cc
+@@ -34,6 +34,7 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <unistd.h>
+
+ #include <algorithm>
+
diff --git a/media-sound/orpheus/files/orpheus-1.6-nolibghttp.patch b/media-sound/orpheus/files/orpheus-1.6-nolibghttp.patch
new file mode 100644
index 000000000000..e6a5f87a210f
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-nolibghttp.patch
@@ -0,0 +1,15 @@
+Index: orpheus-1.6/configure.in
+===================================================================
+--- orpheus-1.6.orig/configure.in
++++ orpheus-1.6/configure.in
+@@ -30,8 +30,8 @@ AM_PATH_XML2(2.0.0, [
+
+ AC_CHECK_LIB(ncurses, main,, AC_CHECK_LIB(curses, main,, AC_MSG_ERROR(The ncurses terminal library is required in order to build the program)))
+
+-AC_CHECK_LIB(ghttp, ghttp_request_new,,
+- [AC_MSG_WARN(libghttp not found - the support for CDDB is be disabled)])
++#AC_CHECK_LIB(ghttp, ghttp_request_new,,
++# [AC_MSG_WARN(libghttp not found - the support for CDDB is be disabled)])
+
+ AC_CHECK_LIB(vorbis, vorbis_synthesis_headerin,,
+ AC_MSG_WARN(libvorbisfile not found - the support for OGG tags edit is disabled))