summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-02 22:17:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-02 22:17:52 +0100
commit6979702826628b893ff22fd57079997eebfe1462 (patch)
tree2da01b6da9955dcf08bf05b4330402bdf249ea15 /media-sound/pamix
parentsys-kernel/gentoo-sources: Linux patch 4.14.11. Removal of redundant patch (diff)
downloadgentoo-6979702826628b893ff22fd57079997eebfe1462.tar.gz
gentoo-6979702826628b893ff22fd57079997eebfe1462.tar.bz2
gentoo-6979702826628b893ff22fd57079997eebfe1462.zip
media-sound/pamix: Fixed QA issues and compilation against ncurses[-tinfo].
Closes: https://bugs.gentoo.org/643148 Closes: https://bugs.gentoo.org/643150 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/pamix')
-rw-r--r--media-sound/pamix/files/pamix-1.6-ncurses_pkgconfig.patch34
-rw-r--r--media-sound/pamix/pamix-1.6.ebuild10
-rw-r--r--media-sound/pamix/pamix-9999.ebuild10
3 files changed, 38 insertions, 16 deletions
diff --git a/media-sound/pamix/files/pamix-1.6-ncurses_pkgconfig.patch b/media-sound/pamix/files/pamix-1.6-ncurses_pkgconfig.patch
new file mode 100644
index 000000000000..c05977166797
--- /dev/null
+++ b/media-sound/pamix/files/pamix-1.6-ncurses_pkgconfig.patch
@@ -0,0 +1,34 @@
+From 90bd2ead3d88b5b24093cb76f9500b69bb0221dd Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 2 Jan 2018 21:24:05 +0100
+Subject: [PATCH] Use pkg-config to reliably find ncurses lib.
+
+Otherwise linking might fail when ncurses was built with separate tinfo lib.
+---
+ CMakeLists.txt | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 38605f2..c7da94e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,11 +17,14 @@ file(GLOB_RECURSE pamix_SRC
+ include_directories("include")
+ link_libraries("pulse" "pthread")
+
++find_package(PkgConfig REQUIRED QUIET)
+ IF (WITH_UNICODE)
+- link_libraries("ncursesw")
++ pkg_search_module(NCURSESW REQUIRED ncursesw)
++ link_libraries(${NCURSESW_LDFLAGS})
+ add_definitions(-DFEAT_UNICODE)
+ ELSE ()
+- link_libraries("ncurses")
++ pkg_search_module(NCURSES REQUIRED ncurses)
++ link_libraries(${NCURSES_LDFLAGS})
+ ENDIF ()
+
+ add_executable(pamix ${pamix_SRC})
+--
+2.16.0.rc0
+
diff --git a/media-sound/pamix/pamix-1.6.ebuild b/media-sound/pamix/pamix-1.6.ebuild
index 19febfb88f4a..dbeb0e57cc75 100644
--- a/media-sound/pamix/pamix-1.6.ebuild
+++ b/media-sound/pamix/pamix-1.6.ebuild
@@ -28,13 +28,9 @@ DEPEND="sys-devel/autoconf-archive
virtual/pkgconfig
${RDEPEND}"
-src_prepare() {
- default
-
- # ugly hackaround for split tinfo ncurses libs
- sed '/link_libraries.*ncurses/s@\(")\)@" "tinfo\1@' \
- -i CMakeLists.txt || die
-}
+PATCHES=(
+ "${FILESDIR}/${P}-ncurses_pkgconfig.patch"
+)
src_configure() {
local mycmakeargs=(
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index acdf22771d05..a3da8fcc45fe 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,14 +28,6 @@ DEPEND="sys-devel/autoconf-archive
virtual/pkgconfig
${RDEPEND}"
-src_prepare() {
- default
-
- # ugly hackaround for split tinfo ncurses libs
- sed '/link_libraries.*ncurses/s@\(")\)@" "tinfo\1@' \
- -i CMakeLists.txt || die
-}
-
src_configure() {
local mycmakeargs=(
-DWITH_UNICODE="$(usex unicode)"