summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-01-09 11:32:28 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-09 11:32:44 +0100
commit5d6ba19feda98dceae4dd9a351c70daa20e733c8 (patch)
tree652b4ea6372b438a479606efbf9b49a4aaf7eaee /media-sound/patchage
parentgnome-base/gnome-desktop: remove old (diff)
downloadgentoo-5d6ba19feda98dceae4dd9a351c70daa20e733c8.tar.gz
gentoo-5d6ba19feda98dceae4dd9a351c70daa20e733c8.tar.bz2
gentoo-5d6ba19feda98dceae4dd9a351c70daa20e733c8.zip
media-sound/patchage: bump to 1.0.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/patchage')
-rw-r--r--media-sound/patchage/Manifest1
-rw-r--r--media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch48
-rw-r--r--media-sound/patchage/patchage-1.0.4.ebuild48
3 files changed, 97 insertions, 0 deletions
diff --git a/media-sound/patchage/Manifest b/media-sound/patchage/Manifest
index 30b106a213b7..36496ca31be7 100644
--- a/media-sound/patchage/Manifest
+++ b/media-sound/patchage/Manifest
@@ -1 +1,2 @@
DIST patchage-1.0.2.tar.bz2 586298 BLAKE2B db52e267dc6ecc246ca5a30d88976c426b607c47c10cf041fe3bb0ab2d6b22d7b3c55a704be0d2fb6b87b3d23d26f15dd49b3d151d3d1dc084f290f4e7ccb01d SHA512 8d59bf4a71c2b41a1c9d8f72da30046568573c6cedaca69815b279fd1c24d44267da6846e219449d47f43157663abc331ef89f241d94dd16e666e06da9f81e12
+DIST patchage-1.0.4.tar.bz2 661824 BLAKE2B 3e56b7513e19e0acb1ef524ba7d7754699abdb6a968547f7a545c8651f23a33c209b9728dae01d839022ec380185a1673ff58733c1553007a6a3b7c889aa7f03 SHA512 665d81ca16c1052f71c3037d2ad8f9a6120b09a323999468484dda1b4c4b567c36728ebe38c54152406b63a4107f04764d0dede52302bc7a7b124e82132749fb
diff --git a/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch b/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
new file mode 100644
index 000000000000..aace519e630d
--- /dev/null
+++ b/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
@@ -0,0 +1,48 @@
+diff --git a/src/JackDbusDriver.cpp b/src/JackDbusDriver.cpp
+index 23c12f2..f49a522 100644
+--- a/src/JackDbusDriver.cpp
++++ b/src/JackDbusDriver.cpp
+@@ -24,6 +24,7 @@
+ #include "SignalDirection.hpp"
+ #include "make_jack_driver.hpp"
+ #include "warnings.hpp"
++#include "AudioDriver.hpp"
+
+ PATCHAGE_DISABLE_FMT_WARNINGS
+ #include <fmt/core.h>
+@@ -61,7 +62,7 @@ namespace {
+ class JackDriver : public AudioDriver
+ {
+ public:
+- explicit JackDriver(ILog& log, EventSink emit_event);
++ explicit JackDriver(ILog& log, Driver::EventSink emit_event);
+
+ JackDriver(const JackDriver&) = delete;
+ JackDriver& operator=(const JackDriver&) = delete;
+@@ -75,7 +76,7 @@ public:
+ void attach(bool launch_daemon) override;
+ void detach() override;
+ bool is_attached() const override;
+- void refresh(const EventSink& sink) override;
++ void refresh(const Driver::EventSink& sink) override;
+ bool connect(const PortID& tail_id, const PortID& head_id) override;
+ bool disconnect(const PortID& tail_id, const PortID& head_id) override;
+
+@@ -129,7 +130,7 @@ private:
+ dbus_uint64_t _graph_version;
+ };
+
+-JackDriver::JackDriver(ILog& log, EventSink emit_event)
++JackDriver::JackDriver(ILog& log, Driver::EventSink emit_event)
+ : AudioDriver{std::move(emit_event)}
+ , _log(log)
+ , _dbus_error()
+@@ -584,7 +585,7 @@ JackDriver::is_attached() const
+ }
+
+ void
+-JackDriver::refresh(const EventSink& sink)
++JackDriver::refresh(const Driver::EventSink& sink)
+ {
+ DBusMessage* reply_ptr = nullptr;
+ DBusMessageIter iter = {};
diff --git a/media-sound/patchage/patchage-1.0.4.ebuild b/media-sound/patchage/patchage-1.0.4.ebuild
new file mode 100644
index 000000000000..24bbd1ab0104
--- /dev/null
+++ b/media-sound/patchage/patchage-1.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+inherit waf-utils python-any-r1 xdg
+
+DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
+HOMEPAGE="http://drobilla.net/software/patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug jack-dbus session"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/boost
+ virtual/pkgconfig
+"
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libglademm:2.4
+ dev-cpp/libgnomecanvasmm:2.6
+ media-libs/ganv
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ jack-dbus? (
+ dev-libs/dbus-glib
+ sys-apps/dbus
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-compilation.patch"
+)
+
+src_configure() {
+ waf-utils_src_configure \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use jack-dbus && echo "--jack-dbus") \
+ $(use session && echo "--jack-session-manage")
+}