summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-06-03 23:09:06 +0200
committerDavid Seifert <soap@gentoo.org>2017-06-03 23:11:14 +0200
commit5c6795a3c355753782b794b860d2a2402bed48f6 (patch)
tree6e44a7adc8bca0761a878f8149283882e4d23993 /media-sound/picard
parentdev-python/mako: Version bump (diff)
downloadgentoo-5c6795a3c355753782b794b860d2a2402bed48f6.tar.gz
gentoo-5c6795a3c355753782b794b860d2a2402bed48f6.tar.bz2
gentoo-5c6795a3c355753782b794b860d2a2402bed48f6.zip
media-sound/picard: [QA] Port to readme.gentoo-r1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/picard-1.3.1.ebuild20
-rw-r--r--media-sound/picard/picard-1.3.2-r1.ebuild18
-rw-r--r--media-sound/picard/picard-1.4.1.ebuild20
-rw-r--r--media-sound/picard/picard-1.4.2.ebuild20
4 files changed, 39 insertions, 39 deletions
diff --git a/media-sound/picard/picard-1.3.1.ebuild b/media-sound/picard/picard-1.3.1.ebuild
index 782c950f877f..dfa121bd47e1 100644
--- a/media-sound/picard/picard-1.3.1.ebuild
+++ b/media-sound/picard/picard-1.3.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
DISABLE_AUTOFORMATTING=true
-inherit eutils distutils-r1 readme.gentoo
+inherit eutils distutils-r1 readme.gentoo-r1
DESCRIPTION="A cross-platform music tagger"
HOMEPAGE="http://picard.musicbrainz.org/"
@@ -26,14 +26,6 @@ RESTRICT="test" # doesn't work with ebuilds
S=${WORKDIR}/${PN}-release-${PV}
DOCS="AUTHORS.txt NEWS.txt"
-DOC_CONTENTS="If you are upgrading Picard and it does not start,
-try removing Picard's settings:
- rm ~/.config/MusicBrainz/Picard.conf
-
-You should set the environment variable BROWSER to something like
- firefox '%s' &
-to let python know which browser to use."
-
src_compile() {
distutils-r1_src_compile $(use nls || echo "--disable-locales")
}
@@ -44,5 +36,13 @@ src_install() {
doicon picard.ico
domenu picard.desktop
+
+ local DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+ firefox '%s' &
+to let python know which browser to use."
readme.gentoo_create_doc
}
diff --git a/media-sound/picard/picard-1.3.2-r1.ebuild b/media-sound/picard/picard-1.3.2-r1.ebuild
index 2e3dfa7a9ee9..1592652f1fdd 100644
--- a/media-sound/picard/picard-1.3.2-r1.ebuild
+++ b/media-sound/picard/picard-1.3.2-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
DISABLE_AUTOFORMATTING=true
-inherit eutils distutils-r1 readme.gentoo
+inherit eutils distutils-r1 readme.gentoo-r1
DESCRIPTION="A cross-platform music tagger"
HOMEPAGE="http://picard.musicbrainz.org/"
@@ -27,14 +27,6 @@ RESTRICT="test" # doesn't work with ebuilds
S=${WORKDIR}/${PN}-release-${PV}
DOCS="AUTHORS.txt NEWS.txt"
-DOC_CONTENTS="If you are upgrading Picard and it does not start,
-try removing Picard's settings:
- rm ~/.config/MusicBrainz/Picard.conf
-
-You should set the environment variable BROWSER to something like
- firefox '%s' &
-to let python know which browser to use."
-
src_compile() {
distutils-r1_src_compile $(use nls || echo "--disable-locales")
}
@@ -45,5 +37,13 @@ src_install() {
doicon picard.ico
domenu picard.desktop
+
+ local DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+ firefox '%s' &
+to let python know which browser to use."
readme.gentoo_create_doc
}
diff --git a/media-sound/picard/picard-1.4.1.ebuild b/media-sound/picard/picard-1.4.1.ebuild
index 16d806db46f4..763fc7e9db21 100644
--- a/media-sound/picard/picard-1.4.1.ebuild
+++ b/media-sound/picard/picard-1.4.1.ebuild
@@ -27,16 +27,6 @@ S="${WORKDIR}/${PN}-release-${PV}"
DOCS=( AUTHORS.txt NEWS.txt README.md )
-DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
-calculation and lookup of AcoustID fingerprints.
-
-Install optional package dev-python/python-discid to enable
-calculation and lookup of compact disc identifiers (disc IDs).
-
-If you are upgrading Picard and it does not start, try removing
-Picard's settings:
- rm ~/.config/MusicBrainz/Picard.conf"
-
python_compile() {
local build_args=(
--disable-autoupdate
@@ -60,6 +50,16 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+
+ local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf"
readme.gentoo_create_doc
}
diff --git a/media-sound/picard/picard-1.4.2.ebuild b/media-sound/picard/picard-1.4.2.ebuild
index 16d806db46f4..763fc7e9db21 100644
--- a/media-sound/picard/picard-1.4.2.ebuild
+++ b/media-sound/picard/picard-1.4.2.ebuild
@@ -27,16 +27,6 @@ S="${WORKDIR}/${PN}-release-${PV}"
DOCS=( AUTHORS.txt NEWS.txt README.md )
-DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
-calculation and lookup of AcoustID fingerprints.
-
-Install optional package dev-python/python-discid to enable
-calculation and lookup of compact disc identifiers (disc IDs).
-
-If you are upgrading Picard and it does not start, try removing
-Picard's settings:
- rm ~/.config/MusicBrainz/Picard.conf"
-
python_compile() {
local build_args=(
--disable-autoupdate
@@ -60,6 +50,16 @@ python_install() {
python_install_all() {
distutils-r1_python_install_all
+
+ local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf"
readme.gentoo_create_doc
}