summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-20 13:16:28 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-20 13:16:28 +0200
commit588abdb8b495e3afccfac126d5d1c20d940b08c1 (patch)
treebce1a7ef16c3b70e2abc41915f1ac3811c06279e /media-sound/pitchtune
parentx11-terms/st: Update live ebuild. (diff)
downloadgentoo-588abdb8b495e3afccfac126d5d1c20d940b08c1.tar.gz
gentoo-588abdb8b495e3afccfac126d5d1c20d940b08c1.tar.bz2
gentoo-588abdb8b495e3afccfac126d5d1c20d940b08c1.zip
media-sound/pitchtune: Fix underlinking (bug #515150).
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/pitchtune')
-rw-r--r--media-sound/pitchtune/files/pitchtune-0.0.4-lm.patch10
-rw-r--r--media-sound/pitchtune/pitchtune-0.0.4.ebuild35
2 files changed, 35 insertions, 10 deletions
diff --git a/media-sound/pitchtune/files/pitchtune-0.0.4-lm.patch b/media-sound/pitchtune/files/pitchtune-0.0.4-lm.patch
new file mode 100644
index 000000000000..b5598846636f
--- /dev/null
+++ b/media-sound/pitchtune/files/pitchtune-0.0.4-lm.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -17,6 +17,7 @@
+ PKG_CHECK_MODULES(GTK, [$pkg_modules])
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
++AC_SEARCH_LIBS(ceil, m)
+
+
+ dnl From glade-2 generated configure.in
diff --git a/media-sound/pitchtune/pitchtune-0.0.4.ebuild b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
index 9490f9b11657..72546e818a05 100644
--- a/media-sound/pitchtune/pitchtune-0.0.4.ebuild
+++ b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
-inherit eutils
+EAPI=6
+inherit autotools eutils
DESCRIPTION="Precise Instrument Tweaking for Crispy Harmony - tuner"
HOMEPAGE="https://sourceforge.net/projects/pitchtune/"
@@ -12,16 +12,31 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-RDEPEND="x11-libs/gtk+:2
- media-libs/alsa-lib"
-DEPEND="${RDEPEND}
- sys-devel/gettext"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ media-libs/alsa-lib
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS README REQUIRED TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.4-lm.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
+
doicon pixmaps/${PN}.xpm
make_desktop_entry ${PN} Pitchtune
- dodoc AUTHORS README REQUIRED TODO
}