summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-05-01 17:06:43 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-01 17:08:17 -0700
commitf1c2076d51472818349ce4b026f5b13a000ce70f (patch)
treeb47c2b5345c99fdd7c9a014fd3de6d3b62a3bf52 /media-sound/pithos
parentdev-python/pylast-3.2.1: Version bump, add py37, py38 (diff)
downloadgentoo-f1c2076d51472818349ce4b026f5b13a000ce70f.tar.gz
gentoo-f1c2076d51472818349ce4b026f5b13a000ce70f.tar.bz2
gentoo-f1c2076d51472818349ce4b026f5b13a000ce70f.zip
media-sound/pithos-1.5.0: version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'media-sound/pithos')
-rw-r--r--media-sound/pithos/Manifest1
-rw-r--r--media-sound/pithos/files/pithos-1.5.0-py38.patch41
-rw-r--r--media-sound/pithos/files/pithos-1.5.0-tests.patch23
-rw-r--r--media-sound/pithos/pithos-1.5.0.ebuild78
4 files changed, 143 insertions, 0 deletions
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index fb71e039cd7b..c6d92b6185b6 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1 +1,2 @@
DIST pithos-1.3.1.tar.gz 119658 BLAKE2B 0d6e1c4e48a4beb1082f8788d4e016371660667dbe32ee925aa4b904f60a25e6664a94cefbc62dd9323a6e69338c03fc4080517e842102fd6eeca144f568c984 SHA512 c06715516992e4aa8bb3b200035ee10ef8dcec9491d32af0fb3f4e176d0ad5313a437f228747d5d716a29d2fe5b93ddd3704aa4fe674ce3be5a17eaad13b0da4
+DIST pithos-1.5.0.tar.gz 123047 BLAKE2B 6f93a41bdda6c3e9baf4d71248748d4e798f9426377fcdf5dded0bdbfec92278f98c215fe818b4d1fc5378d47275539d3a559f7b9d9d8c920f5218431b77c3b3 SHA512 eec2d2fa2fec7f87decc5934d4e1c2f8e11754cb1e042e749be102b27353811a6868636b51b8b9f88ad6f649a12347b82da98d81a476ad3b610ef1049155b657
diff --git a/media-sound/pithos/files/pithos-1.5.0-py38.patch b/media-sound/pithos/files/pithos-1.5.0-py38.patch
new file mode 100644
index 000000000000..dd4327a0d3fd
--- /dev/null
+++ b/media-sound/pithos/files/pithos-1.5.0-py38.patch
@@ -0,0 +1,41 @@
+commit 3a23742614058b4bc97d71e1bb826e19891f0d24
+Author: JasonLG1979 <jasonlevigray3@gmail.com>
+Date: Sun Mar 22 20:50:53 2020 -0500
+
+ Quiet SyntaxWarning: "is" with a literal in Python 3.8
+
+diff --git a/pithos/SearchDialog.py b/pithos/SearchDialog.py
+index d8eec14..fcc9004 100644
+--- a/pithos/SearchDialog.py
++++ b/pithos/SearchDialog.py
+@@ -61,11 +61,11 @@ class SearchDialog(Gtk.Dialog):
+ return
+
+ for i in results:
+- if i.resultType is 'song':
++ if i.resultType == 'song':
+ mk = '<b>{}</b> by {}'.format(html.escape(i.title), html.escape(i.artist))
+- elif i.resultType is 'artist':
++ elif i.resultType == 'artist':
+ mk = '<b>{}</b> (artist)'.format(html.escape(i.name))
+- elif i.resultType is 'genre':
++ elif i.resultType == 'genre':
+ mk = '<b>{}</b> (genre)'.format(html.escape(i.stationName))
+ self.model.append((i, mk))
+ self.treeview.show()
+diff --git a/pithos/StationsDialog.py b/pithos/StationsDialog.py
+index a2b51b2..43cdcb6 100644
+--- a/pithos/StationsDialog.py
++++ b/pithos/StationsDialog.py
+@@ -201,9 +201,9 @@ class StationsDialog(Gtk.Dialog):
+ def add_station_cb(self, dialog, response):
+ result = dialog.result
+ if result is not None:
+- if result.resultType is 'song':
++ if result.resultType == 'song':
+ description = '{} by {}'.format(html.escape(result.title), html.escape(result.artist))
+- elif result.resultType is 'artist':
++ elif result.resultType == 'artist':
+ description = html.escape(result.name)
+ else:
+ description = html.escape(result.stationName)
diff --git a/media-sound/pithos/files/pithos-1.5.0-tests.patch b/media-sound/pithos/files/pithos-1.5.0-tests.patch
new file mode 100644
index 000000000000..cab7639772ef
--- /dev/null
+++ b/media-sound/pithos/files/pithos-1.5.0-tests.patch
@@ -0,0 +1,23 @@
+diff --git a/data/meson.build b/data/meson.build
+index efac217..d08796a 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -41,12 +41,12 @@ pithos_appstream = i18n.merge_file(
+
+ pithos_settings = gnome.compile_schemas()
+
+-appstream_util = find_program('appstream-util', required: false)
+-if appstream_util.found()
+- test('Validate appstream file', appstream_util,
+- args: ['validate', pithos_appstream]
+- )
+-endif
++#appstream_util = find_program('appstream-util', required: false)
++#if appstream_util.found()
++# test('Validate appstream file', appstream_util,
++# args: ['validate', pithos_appstream]
++# )
++#endif
+
+ desktop_utils = find_program('desktop-file-validate', required: false)
+ if desktop_utils.found()
diff --git a/media-sound/pithos/pithos-1.5.0.ebuild b/media-sound/pithos/pithos-1.5.0.ebuild
new file mode 100644
index 000000000000..11ebd44dac4c
--- /dev/null
+++ b/media-sound/pithos/pithos-1.5.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit meson gnome2-utils virtualx python-r1
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="https://pithos.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="appindicator +keybinder libnotify test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ app-crypt/libsecret[introspection]
+ dev-libs/appstream-glib[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/gnome-icon-theme-symbolic
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )
+ libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-libs/glib:2
+ dev-util/desktop-file-utils
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pithos-1.5.0-py38.patch"
+
+ # comment out tests that need internet
+ "${FILESDIR}/pithos-1.5.0-tests.patch"
+)
+
+src_configure() {
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ virtx python_foreach_impl meson_src_test
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}