summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/pragha/pragha-1.1.2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/pragha/pragha-1.1.2.1.ebuild')
-rw-r--r--media-sound/pragha/pragha-1.1.2.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/pragha/pragha-1.1.2.1.ebuild b/media-sound/pragha/pragha-1.1.2.1.ebuild
new file mode 100644
index 000000000000..3c855ed900ec
--- /dev/null
+++ b/media-sound/pragha/pragha-1.1.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic xfconf
+
+DESCRIPTION="A lightweight music player (with support for the Xfce desktop environment)"
+HOMEPAGE="http://pragha.wikispaces.com/ http://github.com/matiasdelellis/pragha"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +glyr lastfm +playlist"
+
+COMMON_DEPEND="dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ >=dev-libs/keybinder-0.2.2:0
+ dev-libs/libcdio-paranoia
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/libcddb-1.3.2
+ >=media-libs/taglib-1.7.1
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.10
+ playlist? ( >=dev-libs/totem-pl-parser-2.26 )
+ glyr? ( >=media-libs/glyr-1.0.1 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:0.10"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(use_enable playlist totem-plparser)
+ )
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-g -ggdb -O0::' configure || die
+ xfconf_src_prepare
+}
+
+src_configure() {
+ # src/cdda.h should #include config.h to get this defined:
+ # http://github.com/matiasdelellis/pragha/issues/46
+ append-cppflags -DHAVE_PARANOIA_NEW_INCLUDES
+ xfconf_src_configure
+}