summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:55:45 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:53 +0100
commitdd8eec12df9439aebe08e2781e8b7c9e1a683f82 (patch)
tree19e29827ee409304c865fb62e2eee9943cde83fb /media-sound/pulseaudio
parentmedia-sound/murmur: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-dd8eec12df9439aebe08e2781e8b7c9e1a683f82.tar.gz
gentoo-dd8eec12df9439aebe08e2781e8b7c9e1a683f82.tar.bz2
gentoo-dd8eec12df9439aebe08e2781e8b7c9e1a683f82.zip
media-sound/pulseaudio: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild2
-rw-r--r--media-sound/pulseaudio/pulseaudio-15.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild
index 0b9a7d18570d..ee5b8c283111 100644
--- a/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild
@@ -313,6 +313,8 @@ multilib_src_install_all() {
pkg_postinst() {
gnome2_schemas_update
if use system-wide; then
+ tmpfiles_process "${PN}.conf"
+
elog "You have enabled the 'system-wide' USE flag for pulseaudio."
elog "This mode should only be used on headless servers, embedded systems,"
elog "or thin clients. It will usually require manual configuration, and is"
diff --git a/media-sound/pulseaudio/pulseaudio-15.0.ebuild b/media-sound/pulseaudio/pulseaudio-15.0.ebuild
index b2bace0883eb..7d6aebdee1db 100644
--- a/media-sound/pulseaudio/pulseaudio-15.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-15.0.ebuild
@@ -304,6 +304,8 @@ pkg_postinst() {
gnome2_schemas_update
if use system-wide; then
+ tmpfiles_process "${PN}.conf"
+
elog "You have enabled the 'system-wide' USE flag for pulseaudio."
elog "This mode should only be used on headless servers, embedded systems,"
elog "or thin clients. It will usually require manual configuration, and is"