summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qmidiarp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qmidiarp')
-rw-r--r--media-sound/qmidiarp/Manifest1
-rw-r--r--media-sound/qmidiarp/files/qmidiarp-0.3.9-ldadd.patch21
-rw-r--r--media-sound/qmidiarp/metadata.xml8
-rw-r--r--media-sound/qmidiarp/qmidiarp-0.3.9.ebuild28
4 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/qmidiarp/Manifest b/media-sound/qmidiarp/Manifest
new file mode 100644
index 000000000000..2546a4e7096c
--- /dev/null
+++ b/media-sound/qmidiarp/Manifest
@@ -0,0 +1 @@
+DIST qmidiarp-0.3.9.tar.bz2 185426 SHA256 0e9b9de1e8f0e54e253a20d985ea923275a006eacc17281f48644b96ae3d01fc
diff --git a/media-sound/qmidiarp/files/qmidiarp-0.3.9-ldadd.patch b/media-sound/qmidiarp/files/qmidiarp-0.3.9-ldadd.patch
new file mode 100644
index 000000000000..127d93167256
--- /dev/null
+++ b/media-sound/qmidiarp/files/qmidiarp-0.3.9-ldadd.patch
@@ -0,0 +1,21 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e2385d0..89cc4a5 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -44,6 +44,8 @@ qmidiarp_SOURCES = \
+ seqdriver.cpp seqdriver.h \
+ slider.cpp slider.h
+
++qmidiarp_LDADD = $(QT_LIBS)
++
+ translationsdir = $(pkgdatadir)/translations
+ translations = \
+ translations/qmidiarp_de.ts \
+@@ -54,7 +56,6 @@ translations_DATA = \
+ translations/qmidiarp_fr.qm
+
+
+-AM_LDFLAGS = @QT_LIBS@ @DEFS@
+ AM_CXXFLAGS = @QT_CXXFLAGS@
+ DEFS = -Wall -Wextra -D_REENTRANT -DTRANSLATIONSDIR=\"$(translationsdir)\" @DEFS@
+
diff --git a/media-sound/qmidiarp/metadata.xml b/media-sound/qmidiarp/metadata.xml
new file mode 100644
index 000000000000..8075e869d631
--- /dev/null
+++ b/media-sound/qmidiarp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">qmidiarp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/qmidiarp/qmidiarp-0.3.9.ebuild b/media-sound/qmidiarp/qmidiarp-0.3.9.ebuild
new file mode 100644
index 000000000000..b6c25ac12166
--- /dev/null
+++ b/media-sound/qmidiarp/qmidiarp-0.3.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="An arpeggiator, sequencer and MIDI LFO for ALSA"
+HOMEPAGE="http://qmidiarp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldadd.patch
+ eautomake
+}