summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:02:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:53 +0100
commitacee938945975798529b2402ee98038ba26844af (patch)
treeffdf5ea501f0d9a010a8f06e7874d416af15ba03 /media-sound/qsynth
parentmedia-libs/sdl-mixer: Add missing media-sound/fluidsynth slot op (diff)
downloadgentoo-acee938945975798529b2402ee98038ba26844af.tar.gz
gentoo-acee938945975798529b2402ee98038ba26844af.tar.bz2
gentoo-acee938945975798529b2402ee98038ba26844af.zip
media-sound/qsynth: 0.5.4 version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.5.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 92c3fefcb871..c4b71a9a6094 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1,3 @@
DIST qsynth-0.5.0.tar.gz 260537 BLAKE2B def589a1cfb76517fa34811fe75a8379043d7e0f9fc661dd456b49414042662c3a3b8f57e2d0de5fae99cbdb60062b12d9b73b93032115648b9a21921766fbeb SHA512 3c7026edfef3115fae8e2167bb961f5e32d886c8d75b3534a3f110d921264cd270953145a4737f9d6660c55fccce81d7306ec0ce4064df6e7226598b52399298
DIST qsynth-0.5.3.tar.gz 269252 BLAKE2B c496063ba33bc78a65d63151871e841f9d3938fe03049655da3c124fd495c592f9c726c479062c3fb2d1561e4dee3284d12b04e04a51ba06e20d297b6e84ac0f SHA512 15632274e5822f5e1a49bd332c5d8b7e59a54800ad32510f425f06b4557e474d5479bd531b45fc43af20535017a656fbd9469d318940931912a56ea1856dc117
+DIST qsynth-0.5.4.tar.gz 268106 BLAKE2B e7e17c1427cbb6105fc6fbaa511325fcfbed0d06e28374e3b9fdce14a633e6554267339bb1ffe2bf1f16fbebf38095ae02eca86d74412add3a1e16d191cd1e45 SHA512 711b18efea3b4050c567f2c549ab4f44525f53de42c6cfea379260e62966215e6d59432bed946733c7e772d691edb739a882de753cf3f46b932833de7b120b7d
diff --git a/media-sound/qsynth/qsynth-0.5.4.ebuild b/media-sound/qsynth/qsynth-0.5.4.ebuild
new file mode 100644
index 000000000000..0e48b9712969
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.5.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+ econf \
+ $(use_enable debug)
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}