summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-10 09:08:01 +0100
committerSam James <sam@gentoo.org>2022-09-10 09:40:21 +0100
commit1b8ee7878128256ad24f4f1f4e2cbfdb4d371943 (patch)
tree08d206995fbbe2e5bf0e541ed094190976466935 /media-sound/qtgain
parentmedia-sound/abcde: EAPI 8 (diff)
downloadgentoo-1b8ee7878128256ad24f4f1f4e2cbfdb4d371943.tar.gz
gentoo-1b8ee7878128256ad24f4f1f4e2cbfdb4d371943.tar.bz2
gentoo-1b8ee7878128256ad24f4f1f4e2cbfdb4d371943.zip
media-sound/qtgain: EAPI 8, optfeature
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/qtgain')
-rw-r--r--media-sound/qtgain/qtgain-1.0.0.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/media-sound/qtgain/qtgain-1.0.0.ebuild b/media-sound/qtgain/qtgain-1.0.0.ebuild
index 30cfbd9acb38..05c73f72ba02 100644
--- a/media-sound/qtgain/qtgain-1.0.0.ebuild
+++ b/media-sound/qtgain/qtgain-1.0.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN="QtGain"
-inherit desktop qmake-utils
+inherit desktop optfeature qmake-utils
DESCRIPTION="Simple frontend to mp3gain, vorbisgain and metaflac"
HOMEPAGE="https://www.linux-apps.com/content/show.php/QtGain?content=56842"
@@ -20,9 +20,8 @@ RDEPEND="
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
-DEPEND="${RDEPEND}
- app-arch/unzip
-"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
S="${WORKDIR}/${PN}"
@@ -37,11 +36,9 @@ src_install() {
}
pkg_postinst() {
- elog "Additional features can be enabled by installing optional packages:"
- elog ""
- elog "media-libs/flac - flac support"
- elog "media-sound/aacgain - aac support"
- elog "media-sound/mp3gain - mp3 support"
- elog "media-sound/vorbisgain - vorbis support"
- elog "media-sound/id3v2 - mass renamer and cover downloader"
+ optfeature "FLAC support" media-libs/flac
+ optfeature "AAC support" media-sound/aacgain
+ optfeature "MP3 support" media-sound/mp3gain
+ optfeature "Vorbis support" media-sound/vorbisgain
+ optfeature "Mass renamer and cover downloader" media-sound/id3v2
}