summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-04 21:15:15 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-04 21:15:31 +1100
commit264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44 (patch)
treed83a2cf267074deca593cebf9baccf179e461854 /media-sound/qtgain
parentapp-emacs/rudel: Remove old. (diff)
downloadgentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.tar.gz
gentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.tar.bz2
gentoo-264551bbcaaefeeaf6e057bc1cd9f2d8c32a5f44.zip
media-sound/qtgain: version bump 1.0.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/qtgain')
-rw-r--r--media-sound/qtgain/Manifest1
-rw-r--r--media-sound/qtgain/qtgain-1.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/qtgain/Manifest b/media-sound/qtgain/Manifest
index 8ca6e7fb63f8..f4c65c0c6054 100644
--- a/media-sound/qtgain/Manifest
+++ b/media-sound/qtgain/Manifest
@@ -1 +1,2 @@
+DIST 56842-QtGain_1.0.0.zip 86401 SHA256 03790318eab370287ebab3be4e55b7a49e35e44ebc12dd6a84da1974d345f31b SHA512 7e95d4f60329bc41db3cb3355ecea0eb214bcbceee403dacd639d14ff4827d551e51c4ffa0fcfb840c9f98b6b17653d2d3a937b6fabdd88f33dbabe315c3c95e WHIRLPOOL 161b1820f5128b9f8cc1e145886fd2a22b5aaf2cd9af6713ba90e5589af14511bdbff574ab4b314786fa0593f647cb3775a065492c62b3f6293473470db6737a
DIST qtgain-0.9.5.tar.lzma 60433 SHA256 4429bae7c034dd9d8fd263d7fe8eeb94a259617e5a8b8fccfe77a1e44fe07ac2 SHA512 00e7f192cd2646326c894003c8e523f9eb125214a750b2a7de48467da75cbacf78100d03d634c3b226b5f0e03810f100fb9dec80db72e4abd4e4ed0af582efc9 WHIRLPOOL f120b93de271ad4b0176eb5cb4008533e056a1ed1b88af9f9ea9f2402afdd2116d53289e452dd215521458fab507c5945a1c619d1e6f8c7d86ad9db27c22007c
diff --git a/media-sound/qtgain/qtgain-1.0.0.ebuild b/media-sound/qtgain/qtgain-1.0.0.ebuild
new file mode 100644
index 000000000000..4a3cab46acb7
--- /dev/null
+++ b/media-sound/qtgain/qtgain-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="QtGain"
+inherit eutils qmake-utils
+
+DESCRIPTION="A simple frontend to mp3gain, vorbisgain and metaflac"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/QtGain?content=56842"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1466640864/56842-${MY_PN}_${PV}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 mp4 vorbis"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+DEPEND="dev-qt/qtgui:4"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ eqmake5 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin bin/${PN}
+ newicon Icons/lsongs.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Additional features can be enabled by installing optional packages:"
+ elog ""
+ elog "media-libs/flac - flac support"
+ elog "media-sound/aacgain - aac support"
+ elog "media-sound/mp3gain - mp3 support"
+ elog "media-sound/vorbisgain - vorbis support"
+ elog "media-sound/id3v2 - mass renamer and cover downloader"
+}