summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-09-05 17:24:57 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-09-05 17:28:53 -0500
commitdf4e651b614771cc13a1ce1738ce36f0a64253db (patch)
tree907284a4cb64f09f92767f6a243ad794e4ff58b5 /media-sound/quodlibet
parentwww-client/lynx: only try to build translation files when nls is enabled (diff)
downloadgentoo-df4e651b614771cc13a1ce1738ce36f0a64253db.tar.gz
gentoo-df4e651b614771cc13a1ce1738ce36f0a64253db.tar.bz2
gentoo-df4e651b614771cc13a1ce1738ce36f0a64253db.zip
media-sound/quodlibet: version bump to 3.9.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-sound/quodlibet')
-rw-r--r--media-sound/quodlibet/Manifest1
-rw-r--r--media-sound/quodlibet/metadata.xml12
-rw-r--r--media-sound/quodlibet/quodlibet-3.9.1.ebuild72
3 files changed, 79 insertions, 6 deletions
diff --git a/media-sound/quodlibet/Manifest b/media-sound/quodlibet/Manifest
index 07ce35829320..533f5b901d39 100644
--- a/media-sound/quodlibet/Manifest
+++ b/media-sound/quodlibet/Manifest
@@ -1,2 +1,3 @@
DIST quodlibet-3.7.1.tar.gz 3651908 SHA256 229a26289880860abfd0ec31d9f0aa830c84a3f78205feb11f3ec710e02f02cd SHA512 73f2a909e29178fb4074dbf451a6d04170aebecb7934248b04b909f9639c9098054eefe3343cfb67cc3c622f6d453b5417e5233d4d2ec9c87c48a0c5b4debf4f WHIRLPOOL 2149daf74da7bc01a9822d841de7634c72cca02ef2ab59ae8ac2cd4716e72bed2d6f3342c3b32ddd66c393ecab7c311729e424175a8c7264de0edf2525391187
DIST quodlibet-3.8.1.tar.gz 3697363 SHA256 7c26ddd391a7b3d2bcdb4b009b005db604a133a059499284613436a88d164401 SHA512 5f8f7ba3157dea83782c64989114ad38295c660300284b72e825eba46eae053120c96e60518d573b4010dd49e396a4fe8d04788e632e61e38fa6edd953014275 WHIRLPOOL b3d73a78dbf77b14d04e6fdb1c1b154a9106d364e62d55f25acc7e750eed6cf39a6584b3c9409bd1cb45d322ebd3268e45e36bfc455647fa2c9fbe7961648a3b
+DIST quodlibet-3.9.1.tar.gz 3850929 SHA256 75dcbac8ec4452f501be775d81d1690230d14de09ad0c788a7dff57db22bffc6 SHA512 6d6b6380de2fc2d3ab1614b304f2d7219ff1d823e03f532baa0e9b1308fd36094ad745433494253d956182ae9914eb62846df3d3e5fea92dddccdaa725178563 WHIRLPOOL ad60e6d7216910e56fc9aecdd068fac09fee26bd8e5b749f2926d9b68a1d84ef61008869635490efad0eb8e84934d7643b03c3d65d7c2881c4cfa420ae36f969
diff --git a/media-sound/quodlibet/metadata.xml b/media-sound/quodlibet/metadata.xml
index 34f78c18921b..6c2b729f2933 100644
--- a/media-sound/quodlibet/metadata.xml
+++ b/media-sound/quodlibet/metadata.xml
@@ -14,12 +14,12 @@
<name>Gentoo Sound project</name>
</maintainer>
<longdescription>Quod Libet is a GTK+-based audio player written in Python. It's
- designed around the idea that you know better than we do how to
- organize your music. It lets you make playlists based on regular
- expressions (don't worry, regular searches work too). It lets you
- display and edit any tags you want in the file. And it lets you do
- this for all the file formats it supports -- Ogg Vorbis, FLAC, MP3,
- Musepack, and MOD.</longdescription>
+ designed around the idea that you know better than we do how to
+ organize your music. It lets you make playlists based on regular
+ expressions (don't worry, regular searches work too). It lets you
+ display and edit any tags you want in the file. And it lets you do
+ this for all the file formats it supports -- Ogg Vorbis, FLAC, MP3,
+ Musepack, and MOD.</longdescription>
<upstream>
<remote-id type="google-code">quodlibet</remote-id>
<remote-id type="github">quodlibet/quodlibet</remote-id>
diff --git a/media-sound/quodlibet/quodlibet-3.9.1.ebuild b/media-sound/quodlibet/quodlibet-3.9.1.ebuild
new file mode 100644
index 000000000000..aa76a36cecfc
--- /dev/null
+++ b/media-sound/quodlibet/quodlibet-3.9.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="audio library tagger, manager, and player for GTK+"
+HOMEPAGE="http://quodlibet.readthedocs.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+dbus gstreamer ipod +udev"
+
+RDEPEND="dev-libs/keybinder:3[introspection]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/futures[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=media-libs/mutagen-1.32[${PYTHON_USEDEP}]
+ net-libs/libsoup[introspection]
+ x11-libs/gtk+[introspection]
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ !gstreamer? ( media-libs/xine-lib )
+ dbus? (
+ app-misc/media-player-info
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ )
+ ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] )
+ udev? ( virtual/udev )
+ !media-plugins/quodlibet-plugins"
+DEPEND="dev-util/intltool"
+REQUIRED_USE="ipod? ( dbus )"
+
+S="${WORKDIR}/${PN}-release-${PV}/${PN}"
+
+src_prepare() {
+ local qlconfig=${PN}/config.py
+
+ if ! use gstreamer; then
+ sed -i -e '/backend/s:gstbe:xinebe:' ${qlconfig} || die
+ fi
+
+ sed -i -e '/gst_pipeline/s:"":"alsasink":' ${qlconfig} || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg-utils_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg-utils_desktop_database_update
+ gnome2_icon_cache_update
+}