summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-11 21:45:11 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-11 21:47:14 +0100
commit6a898fff45993a04ecd991c29c15c92b86400c4e (patch)
tree3650c0e83a54e9c03202f1f9dbd32bbd554ee8ee /media-sound/rexima/rexima-1.4-r1.ebuild
parentmedia-sound/takcd: Modernise to EAPI 6 (diff)
downloadgentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.tar.gz
gentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.tar.bz2
gentoo-6a898fff45993a04ecd991c29c15c92b86400c4e.zip
media-sound/rexima: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/rexima/rexima-1.4-r1.ebuild')
-rw-r--r--media-sound/rexima/rexima-1.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/rexima/rexima-1.4-r1.ebuild b/media-sound/rexima/rexima-1.4-r1.ebuild
new file mode 100644
index 000000000000..cd78692ee670
--- /dev/null
+++ b/media-sound/rexima/rexima-1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based interactive mixer which can also be used from the command-line"
+HOMEPAGE="http://www.svgalib.org/rus/rexima.html"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/mixers/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ tc-export CC
+
+ cat > Makefile <<- _EOF_ || die
+ LDLIBS=$($(tc-getPKG_CONFIG) --libs ncurses)
+ all: rexima
+ _EOF_
+}
+
+src_install () {
+ dobin rexima
+
+ einstalldocs
+ doman rexima.1
+}