summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-10 04:45:52 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-10 04:45:52 +0200
commitaad488a39b9a8c024c4e2df647891fc5f3fd3bed (patch)
tree2253db4c93a894cc1a8232d42e52c761e1372d1b /media-sound/rgain
parentapp-i18n/poedit: bump to 2.0.5 (diff)
downloadgentoo-aad488a39b9a8c024c4e2df647891fc5f3fd3bed.tar.gz
gentoo-aad488a39b9a8c024c4e2df647891fc5f3fd3bed.tar.bz2
gentoo-aad488a39b9a8c024c4e2df647891fc5f3fd3bed.zip
media-sound/rgain: use gst-plugins-meta instead of guessing what plugin packages are needed
mp3 decoder changed to gst-plugins-mpg123 and gst-plugins-mad will be removed, this package was explicitly requesting gst-plugins-mad instead of letting gst-plugins-meta handle it. Switch to meta for all of them to avoid such issues in the future too. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/rgain')
-rw-r--r--media-sound/rgain/rgain-1.2.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/rgain/rgain-1.2.1-r1.ebuild b/media-sound/rgain/rgain-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..76302e53f211
--- /dev/null
+++ b/media-sound/rgain/rgain-1.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of programmes and Python modules to deal with Replay Gain information"
+HOMEPAGE="https://bitbucket.org/fk/rgain"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac mp3 vorbis wavpack"
+
+DEPEND=">=dev-python/docutils-0.9"
+RDEPEND="media-libs/mutagen
+ dev-python/pygobject:3[$PYTHON_USEDEP]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[flac?,mp3?,vorbis?,wavpack?]
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman build/man/*
+}