summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/rosegarden/rosegarden-14.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/rosegarden/rosegarden-14.12.ebuild')
-rw-r--r--media-sound/rosegarden/rosegarden-14.12.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/rosegarden/rosegarden-14.12.ebuild b/media-sound/rosegarden/rosegarden-14.12.ebuild
new file mode 100644
index 000000000000..b4960e032345
--- /dev/null
+++ b/media-sound/rosegarden/rosegarden-14.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fdo-mime gnome2-utils multilib
+
+DESCRIPTION="MIDI and audio sequencer and notation editor"
+HOMEPAGE="http://www.rosegardenmusic.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug lirc"
+
+RDEPEND="dev-qt/qtgui:4
+ media-libs/ladspa-sdk:=
+ x11-libs/libSM:=
+ media-sound/jack-audio-connection-kit:=
+ media-libs/alsa-lib:=
+ >=media-libs/dssi-1.0.0:=
+ media-libs/liblo:=
+ media-libs/liblrdf:=
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate:=[sndfile]
+ lirc? ( app-misc/lirc:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-misc/makedepend"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-12.12.25-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ export USER_CXXFLAGS="${CXXFLAGS}"
+
+ export ac_cv_header_lirc_lirc_client_h=$(usex lirc)
+ export ac_cv_lib_lirc_client_lirc_init=$(usex lirc)
+
+ econf \
+ $(use_enable debug) \
+ --with-qtdir=/usr \
+ --with-qtlibdir=/usr/$(get_libdir)/qt4
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}