summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch')
-rw-r--r--media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
new file mode 100644
index 000000000000..07128bb95596
--- /dev/null
+++ b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
@@ -0,0 +1,59 @@
+--- configure.in
++++ configure.in
+@@ -83,22 +83,29 @@
+
+ dnl -- configure options --
+
+-XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!(Perhaps you need --with-ogg-prefix=/usr/local)))
+-XIPH_PATH_VORBIS(, AC_MSG_ERROR(must have Vorbis installed!(Perhaps you need --with-vorbis-prefix=/usr/local)))
+-AM_PATH_CURL(,,AC_MSG_ERROR(must have libcurl installed!))
+-AM_PATH_MAD(, AC_MSG_ERROR(must have libmad installed!))
+-AM_PATH_LAME(, AC_MSG_ERROR(must have libmp3lame installed!))
++PKG_CHECK_MODULES([OGG],[ogg])
++PKG_CHECK_MODULES([VORBIS],[vorbis])
++PKG_CHECK_MODULES([VORBISENC],[vorbisenc])
++PKG_CHECK_MODULES([VORBISFILE],[vorbisfile])
++PKG_CHECK_MODULES([CURL],[libcurl])
++PKG_CHECK_MODULES([MAD],[mad])
++
++AC_PATH_PROG([LAME],[lame])
+
+ dnl Make substitutions
+
+ AC_SUBST(MAD_CFLAGS)
+ AC_SUBST(MAD_LIBS)
+ AC_SUBST(LAME_CFLAGS)
+-AC_SUBST(LAME_LIBS)
++AC_SUBST([LAME_LIBS],[-lmp3lame])
+ AC_SUBST(OGG_CFLAGS)
+ AC_SUBST(VORBIS_CFLAGS)
++AC_SUBST(VORBISENC_CFLAGS)
++AC_SUBST(VORBISFILE_CFLAGS)
+ AC_SUBST(OGG_LIBS)
+ AC_SUBST(VORBIS_LIBS)
++AC_SUBST(VORBISENC_LIBS)
++AC_SUBST(VORBISFILE_LIBS)
+ AC_SUBST(LIBTOOL_DEPS)
+ AC_SUBST(OPT)
+ AC_SUBST(LIBS)
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -17,5 +17,6 @@
+
+ INCLUDES = -I$(srcdir)/liboddcast -I$(srcdir)/libtranscoder
+
+-install-hook:
+- cp transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
++install-data-hook:
++ $(INSTALL) -d $(DESTDIR)$(sysconfdir)
++ $(INSTALL) -m644 transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
+--- src/libtranscoder/transcurl.cpp
++++ src/libtranscoder/transcurl.cpp
+@@ -18,7 +18,6 @@
+ #include <winsock2.h>
+ #endif
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include "transcurl.h"
+ #include "cbuffer.h"