summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-20 19:48:57 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-20 19:48:57 +0100
commit3c1697a7ba213a80219248d977932e0c0bc89bf8 (patch)
treeb4db361b544a9fb8447297c17213dfd04570103f /media-sound/synaesthesia
parentmedia-sound/SmarTagger: update EAPI 6 -> 8 (diff)
downloadgentoo-3c1697a7ba213a80219248d977932e0c0bc89bf8.tar.gz
gentoo-3c1697a7ba213a80219248d977932e0c0bc89bf8.tar.bz2
gentoo-3c1697a7ba213a80219248d977932e0c0bc89bf8.zip
media-sound/synaesthesia: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/synaesthesia')
-rw-r--r--media-sound/synaesthesia/files/synaesthesia-2.4-inline-keyword.patch14
-rw-r--r--media-sound/synaesthesia/files/synaesthesia-2.4-respect-flags.patch11
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.4-r1.ebuild (renamed from media-sound/synaesthesia/synaesthesia-2.4.ebuild)17
3 files changed, 33 insertions, 9 deletions
diff --git a/media-sound/synaesthesia/files/synaesthesia-2.4-inline-keyword.patch b/media-sound/synaesthesia/files/synaesthesia-2.4-inline-keyword.patch
new file mode 100644
index 000000000000..ef93f24029bb
--- /dev/null
+++ b/media-sound/synaesthesia/files/synaesthesia-2.4-inline-keyword.patch
@@ -0,0 +1,14 @@
+--- a/syna.h
++++ b/syna.h
+@@ -73,9 +73,9 @@
+ #endif
+
+ void error(char *str,bool syscall=false);
+-void inline attempt(int x,char *y,bool syscall=false) { if (x == -1) error(y,syscall); }
++inline void attempt(int x,char *y,bool syscall=false) { if (x == -1) error(y,syscall); }
+ void warning(char *str,bool syscall=false);
+-void inline attemptNoDie(int x,char *y,bool syscall=false) { if (x == -1) warning(y,syscall); }
++inline void attemptNoDie(int x,char *y,bool syscall=false) { if (x == -1) warning(y,syscall); }
+
+ /* *wrap */
+ struct BaseScreen {
diff --git a/media-sound/synaesthesia/files/synaesthesia-2.4-respect-flags.patch b/media-sound/synaesthesia/files/synaesthesia-2.4-respect-flags.patch
new file mode 100644
index 000000000000..7a9523ee8b9a
--- /dev/null
+++ b/media-sound/synaesthesia/files/synaesthesia-2.4-respect-flags.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -1664,8 +1664,6 @@
+ ac_config_commands="$ac_config_commands default-1"
+
+
+-CXXFLAGS="-O4"
+-CFLAGS="-O4"
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
diff --git a/media-sound/synaesthesia/synaesthesia-2.4.ebuild b/media-sound/synaesthesia/synaesthesia-2.4-r1.ebuild
index e431ff390070..57f8faec27b7 100644
--- a/media-sound/synaesthesia/synaesthesia-2.4.ebuild
+++ b/media-sound/synaesthesia/synaesthesia-2.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="a nice graphical accompaniment to music"
HOMEPAGE="http://www.logarithmic.net/pfh/synaesthesia"
@@ -12,16 +12,15 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="sdl svga"
-RDEPEND="x11-libs/libXext
+RDEPEND="
+ x11-libs/libXext
x11-libs/libSM
sdl? ( >=media-libs/libsdl-1.2 )
svga? ( >=media-libs/svgalib-1.4.3 )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-src_prepare() {
- default
- sed -e '/CFLAGS=/s:-O4:${CFLAGS}:' \
- -e '/CXXFLAGS=/s:-O4:${CXXFLAGS}:' -i configure || die "sed failed"
- sed -e 's:void inline:inline void:' -i syna.h || die "sed failed"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-inline-keyword.patch
+)