summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-09-24 08:33:39 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-09-24 08:33:50 +0200
commitb3be7727d1be1c0d876eccf062ca40fb0ffb5e31 (patch)
tree363a1afb4a4bc64f6bfe8ad45585ac29a0dde301 /media-sound/terminatorx
parentdev-python/xdoctest: Remove old (diff)
downloadgentoo-b3be7727d1be1c0d876eccf062ca40fb0ffb5e31.tar.gz
gentoo-b3be7727d1be1c0d876eccf062ca40fb0ffb5e31.tar.bz2
gentoo-b3be7727d1be1c0d876eccf062ca40fb0ffb5e31.zip
media-sound/terminatorx: bump to 4.1.0
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/terminatorx')
-rw-r--r--media-sound/terminatorx/Manifest1
-rw-r--r--media-sound/terminatorx/files/terminatorx-4.1.0-metadata-dir.patch13
-rw-r--r--media-sound/terminatorx/terminatorx-4.1.0.ebuild59
3 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/terminatorx/Manifest b/media-sound/terminatorx/Manifest
index 65b3c158b6c4..5b70309c9c5d 100644
--- a/media-sound/terminatorx/Manifest
+++ b/media-sound/terminatorx/Manifest
@@ -1 +1,2 @@
DIST terminatorX-4.0.1.tar.bz2 1832692 BLAKE2B 61eeb6362cdf56cb73df3bfbff65cf3699a0ef686d77894b87feab5f25f927267bc28573c3ee41981ded3b452b1d37c035260ffbe0fdcf6d0b0c0319c61a6137 SHA512 06128633e128f2158367dcde0e913dafc68d62644e7a5182a2391829dadcb9c46430d0cac16cb17113939623266f32cb4624a8548a51b8c01bdfa2860a6c0093
+DIST terminatorX-4.1.0.tar.bz2 1832295 BLAKE2B a328d05bb0c3c88719eb711dcf3f50eac08cd140e3225f42633744b39ce49f3e074263997ec21b2cc245740fa3f672a19b89d929fad1d0131981988fc80f37fc SHA512 2dc87bdbb4f4d24e10f0c8fac99b4ccecac6036c6dc950184cbdd1d05fe0a4c723ea1b04c49837fb0aa8f149ca9d2fb5d2c42f5109031184980a14fe549312fc
diff --git a/media-sound/terminatorx/files/terminatorx-4.1.0-metadata-dir.patch b/media-sound/terminatorx/files/terminatorx-4.1.0-metadata-dir.patch
new file mode 100644
index 000000000000..3f873271e00b
--- /dev/null
+++ b/media-sound/terminatorx/files/terminatorx-4.1.0-metadata-dir.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index cd70e20..5b9a142 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -362,7 +362,7 @@ EXTRA_DIST = COPYING-DOCS\
+ # Destkop Entry
+ desktopdir = $(datadir)/applications
+ desktop_DATA = terminatorX.desktop
+-appdatadir = $(datarootdir)/appdata
++appdatadir = $(datarootdir)/metadata
+ appdata_DATA = terminatorX.appdata.xml
+ mimedir = $(datadir)/mime-info
+ mime_DATA = terminatorX.mime terminatorX.keys
diff --git a/media-sound/terminatorx/terminatorx-4.1.0.ebuild b/media-sound/terminatorx/terminatorx-4.1.0.ebuild
new file mode 100644
index 000000000000..656edc4f99a2
--- /dev/null
+++ b/media-sound/terminatorx/terminatorx-4.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+MY_P=${P/terminatorx/terminatorX}
+
+DESCRIPTION="Realtime audio synthesizer allowing you to 'scratch' on sampled audio data"
+HOMEPAGE="http://www.terminatorx.org/"
+SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Making X optional fails when disabled: https://bugs.gentoo.org/636832
+IUSE="alsa debug mad pulseaudio vorbis sox"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-sound/madplay )
+ pulseaudio? ( media-sound/pulseaudio )
+ vorbis? ( media-libs/libvorbis )
+ sox? ( media-sound/sox
+ media-sound/mpg123 )
+ x11-libs/gtk+:3
+ >=dev-libs/glib-2.2:2
+
+ x11-libs/libXi
+ x11-libs/libXxf86dga
+
+ dev-libs/libxml2:2
+ media-libs/audiofile:=
+ media-libs/ladspa-sdk
+ media-libs/liblrdf
+ media-plugins/cmt-plugins
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ app-text/gnome-doc-utils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-metadata-dir.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-x11 \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable mad) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable vorbis) \
+ $(use_enable sox)
+}