summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-25 15:59:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-25 15:59:04 +0200
commitb4375495951bd3383479cdad7c729a40ca4a6378 (patch)
tree6389407c527e4464f570a3f387ace70e9055bb39 /media-sound/volumeicon
parentkde-apps/konsole: introduce minimal USE flag for Plasma 5 compatibility. (diff)
downloadgentoo-b4375495951bd3383479cdad7c729a40ca4a6378.tar.gz
gentoo-b4375495951bd3383479cdad7c729a40ca4a6378.tar.bz2
gentoo-b4375495951bd3383479cdad7c729a40ca4a6378.zip
media-sound/volumeicon: bump to 0.5.1.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound/volumeicon')
-rw-r--r--media-sound/volumeicon/Manifest1
-rw-r--r--media-sound/volumeicon/volumeicon-0.5.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/volumeicon/Manifest b/media-sound/volumeicon/Manifest
index 645acb5dc1ef..05bc3e07c29b 100644
--- a/media-sound/volumeicon/Manifest
+++ b/media-sound/volumeicon/Manifest
@@ -1,2 +1,3 @@
DIST volumeicon-0.4.6.tar.gz 136769 SHA256 32f94adc5f346404ae564405dd483ae4bd04212df08e46f18d369b4ba2cb6590
DIST volumeicon-0.5.0.tar.gz 160089 SHA256 e5f1179f9ec5ab25e3740e4f6bbe0baa75368f0ae87d370197b3fbefb61bd782 SHA512 26c4973a600495886222920e6eea80a7d54ebecf9b9fa46dea6808e25bf3b5edc5b37ff0740da270e77faac687d2151d8cc53259b356e17ce99ed0e38b7fbe38 WHIRLPOOL 1f319c1a671be3677f02272683a36b4714d728d5022f1e640c2b0d130d80dc1958c07a8a5d28637ba47d7ac91d021676774cba90bae050d726c6d05132b980cc
+DIST volumeicon-0.5.1.tar.gz 172401 SHA256 24b8c1d0a81d708b201ce6e67301fc175d65588d892d01859f667b8db8a05da0 SHA512 a96c79f91a8a0ec96f3297af659cf738547bb33e5908edb6b499bcc5081c61339ceaccc3a854a2f953a6f177fe6d8be1578cacab522d8be63a9dda8cf7c7a452 WHIRLPOOL 7dc58c6bc00cc53edb5ba6b945ad9fb328ad6e1a52beea3fe85d7afddafdd21fc6ddeb6807442491bf7784563d5c85fc48fa67bb21f607ee31aec76b90fd3d82
diff --git a/media-sound/volumeicon/volumeicon-0.5.1.ebuild b/media-sound/volumeicon/volumeicon-0.5.1.ebuild
new file mode 100644
index 000000000000..b6015935f675
--- /dev/null
+++ b/media-sound/volumeicon/volumeicon-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A lightweight volume control that sits in your systray"
+HOMEPAGE="http://softwarebakery.com/maato/volumeicon.html"
+SRC_URI="http://softwarebakery.com/maato/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+src_configure() {
+ # $(use_enable !alsa oss) fails wrt #419891, is likely only for OSS4
+ econf $(use_enable libnotify notify)
+}