summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/wavbreaker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/wavbreaker')
-rw-r--r--media-sound/wavbreaker/Manifest1
-rw-r--r--media-sound/wavbreaker/files/wavbreaker-0.10-pkgconfig.patch11
-rw-r--r--media-sound/wavbreaker/metadata.xml8
-rw-r--r--media-sound/wavbreaker/wavbreaker-0.11.ebuild38
4 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/wavbreaker/Manifest b/media-sound/wavbreaker/Manifest
new file mode 100644
index 000000000000..4a0665f8ada3
--- /dev/null
+++ b/media-sound/wavbreaker/Manifest
@@ -0,0 +1 @@
+DIST wavbreaker-0.11.tar.gz 496733 SHA256 a1d70fc54f92f20fb4cc2ef01beb8f60bc5e8d1cedde6b1e5f8f453b14ead2d1 SHA512 3dee23ef7c0db651cd1ebae78db3f950b5b22ae4f0a323f66e1243a88c0e41390f9f4abde663ef7a1d1c841e0cbb779612d6078cd327a0f1d48e6a812c8ce4e1 WHIRLPOOL e8072cfec4597a1e1ff9da6d65422d96c3586efdfc2829acf5f23e850b66bdf9f0113bd5140a7d69b0d8c352eefc5ee39f814fdaa9a6d8e54c6eaa92b7e4d98d
diff --git a/media-sound/wavbreaker/files/wavbreaker-0.10-pkgconfig.patch b/media-sound/wavbreaker/files/wavbreaker-0.10-pkgconfig.patch
new file mode 100644
index 000000000000..06a3d04adcba
--- /dev/null
+++ b/media-sound/wavbreaker/files/wavbreaker-0.10-pkgconfig.patch
@@ -0,0 +1,11 @@
+diff -ur wavbreaker-0.10.orig/configure.in wavbreaker-0.10/configure.in
+--- wavbreaker-0.10.orig/configure.in 2008-06-02 09:44:27.000000000 +0300
++++ wavbreaker-0.10/configure.in 2008-06-14 15:28:26.000000000 +0300
+@@ -30,6 +30,7 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
++PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+ AC_CHECK_LIB([m], [cos])
diff --git a/media-sound/wavbreaker/metadata.xml b/media-sound/wavbreaker/metadata.xml
new file mode 100644
index 000000000000..be77b558ac12
--- /dev/null
+++ b/media-sound/wavbreaker/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">wavbreaker</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/wavbreaker/wavbreaker-0.11.ebuild b/media-sound/wavbreaker/wavbreaker-0.11.ebuild
new file mode 100644
index 000000000000..0829894cc19a
--- /dev/null
+++ b/media-sound/wavbreaker/wavbreaker-0.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="wavbreaker/wavmerge GTK+ utility to break or merge WAV files"
+HOMEPAGE="http://wavbreaker.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alsa nls oss pulseaudio"
+
+RDEPEND="dev-libs/libxml2
+ >=x11-libs/gtk+-2:2
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog CONTRIBUTORS NEWS README* TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10-pkgconfig.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable oss)
+}