summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:13:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 15:30:50 +0100
commit9587e4463685465b87d12026397e84586a109838 (patch)
tree34a109347eb6bfb6eda3c8e9e1768ff449e356bc /media-sound/yoshimi
parentapp-dicts/myspell-nl: sparc stable wrt bug #704350 (diff)
downloadgentoo-9587e4463685465b87d12026397e84586a109838.tar.gz
gentoo-9587e4463685465b87d12026397e84586a109838.tar.bz2
gentoo-9587e4463685465b87d12026397e84586a109838.zip
*/*: Switch sound proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/yoshimi')
-rw-r--r--media-sound/yoshimi/yoshimi-1.5.10.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-sound/yoshimi/yoshimi-1.5.10.2.ebuild b/media-sound/yoshimi/yoshimi-1.5.10.2.ebuild
index 4acbf0c9ea5c..442d7fa96369 100644
--- a/media-sound/yoshimi/yoshimi-1.5.10.2.ebuild
+++ b/media-sound/yoshimi/yoshimi-1.5.10.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Software synthesizer based on ZynAddSubFX"
HOMEPAGE="https://yoshimi.github.io/"
@@ -38,7 +38,7 @@ PATCHES=( "${FILESDIR}"/${P}-cxxflags.patch )
DOCS=( Changelog README.txt )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# respect doc dir
sed -e "s#/doc/yoshimi#/doc/${PF}#" -i src/CMakeLists.txt || die
}
@@ -47,5 +47,5 @@ src_configure() {
local mycmakeargs=(
-DLV2Plugin=$(usex lv2)
)
- cmake-utils_src_configure
+ cmake_src_configure
}