summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2022-05-16 16:48:14 +0200
committerMatt Turner <mattst88@gentoo.org>2022-05-16 12:29:54 -0400
commit0606f6709ccba07270b28820e5eee96ff98aee7d (patch)
tree884416d90ea581f10f53c12093f3c21de2f31b2a /media-sound
parentapp-portage/gpyutils: Bump to 0.6.2 (diff)
downloadgentoo-0606f6709ccba07270b28820e5eee96ff98aee7d.tar.gz
gentoo-0606f6709ccba07270b28820e5eee96ff98aee7d.tar.bz2
gentoo-0606f6709ccba07270b28820e5eee96ff98aee7d.zip
media-sound/rhythmbox: drop strict meson version check
Closes: https://bugs.gentoo.org/845006 Closes: https://github.com/gentoo/gentoo/pull/25526 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch42
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.4.5.ebuild2
2 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch b/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch
new file mode 100644
index 000000000000..2843a4c0cabc
--- /dev/null
+++ b/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch
@@ -0,0 +1,42 @@
+https://github.com/GNOME/rhythmbox/commit/29a1627f1683aac358103710ffc1a51791951edd
+https://bugs.gentoo.org/845006
+--- a/meson.build
++++ b/meson.build
+@@ -3,10 +3,6 @@ project('rhythmbox', 'c',
+ meson_version: '>= 0.59.0',
+ default_options: ['c_std=gnu89'])
+
+-if meson.version().version_compare('> 0.62.0')
+- error('unsupported version of meson, please use 0.62')
+-endif
+-
+ gnome = import('gnome')
+ i18n = import('i18n')
+ pkg = import('pkgconfig')
+GitLab
+From 0fe3a388fac73a5d4217aed510d65976850734c4 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 4 May 2022 10:23:16 +0200
+Subject: [PATCH 2/2] ci: Install latest meson
+
+--- a/.gitlab-ci.yml
++++ b/.gitlab-ci.yml
+@@ -4,8 +4,6 @@ stages:
+ - test
+
+ variables:
+- MESON_VER: 0.62.0
+-
+ UBUNTU_DEPS:
+ build-essential
+ desktop-file-utils
+@@ -64,7 +62,7 @@ before_script:
+ - export DEBIAN_FRONTEND=noninteractive
+ - apt-get update
+ - apt-get install -y $UBUNTU_DEPS
+- - pip3 install meson==$MESON_VER
++ - pip3 install meson
+
+ test:
+ stage: test
+GitLab
diff --git a/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild b/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild
index 2e7dc2b30fd4..c4b440ad855b 100644
--- a/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild
@@ -93,6 +93,8 @@ BDEPEND="
test? ( dev-libs/check )
"
+PATCHES=( "${FILESDIR}/${PV}"-relax-meson-version-check.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}